Websites not working

Discussion in 'Installation/Configuration' started by kassie, Nov 28, 2008.

  1. kassie

    kassie New Member

    Hi All,

    I have Ubuntu 8.10 perfect server with ISPConfig 2.2.27

    Last night I did the following
    apt-get update
    apt-get upgrade

    It found a couple of things to do. During the upgrade it asked me to keep older files or overwrite them. I chose overwrite... (I know,, my bad:confused:)

    The only site that works is the ISPConfig Web Interface.
    All my other websites now says "It works".

    Any suggestions to the problem?

    I have done the following since:
    Dowload ISPConfig 2.2.27 again and ran the setup. - Did not fix it.
     
    Last edited: Nov 28, 2008
  2. kassie

    kassie New Member

    Is there any way to fix this??
     
  3. _X_

    _X_ New Member

    check your /etc/apache2/vhosts/Vhosts_ispconfig.conf
    and nameserver in ISPConfig Management/server/settings>DNS
    Default NS1 and NS2
     
  4. kassie

    kassie New Member

    Thanks for the reply.

    I have checked /etc/apache2/vhosts/Vhosts_ispconfig.conf - It has all my vhosts in the file. I have also checked the DNS servers. It is pointing to my local machine.

    Any other suggestions??
     
  5. _X_

    _X_ New Member

    what does this mean?
     
  6. kassie

    kassie New Member

    The DNS Server in ISPConfig has always pointed to the IP Address of my server

    10.0.2.24

    It was like that from the start. The server is running like that for almost a year. It is only since i had apache overwrite some of the files when upgrading.
     
    Last edited: Nov 30, 2008
  7. falko

    falko Super Moderator ISPConfig Developer

    Make sure you have this at the end of /etc/apache2/apache2.conf:

    Code:
    <Directory /var/www/sharedip>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    #CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
    
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/cgi-bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
     
  8. kassie

    kassie New Member

    Thanks Falko

    Youre the man....


    This is 1 thing i rate tops of ISPConfig.

    The guys that wrote it, knows it.

    Great work guys, keep it up....
     

Share This Page