Websites not Loading after upgrading to Unbuntu 18.04.1

Discussion in 'General' started by Chris H, Sep 26, 2018.

  1. Chris H

    Chris H New Member

    So I upgraded from unbuntu 16.04 to 18.04 and it has broken some things.
    There seems to be some issue with PHP and ispconfig and maybe mysql as well. FTP works and mail works, but I cant access sites or the ispconfig admin panel, which gives me a 500 error. Plain HTML pages will load fine, I need some direction on where to look to get things back up and running again.

    I would not be opposed to just uninstalling ispconfig and reinstalling however the uninstaller does not work it throws this error when trying to run the uninstall command:

    Code:
    php -q uninstall.php
    PHP Fatal error:  Uncaught Error: Call to undefined function mysqli_connect() in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php:79
    Stack trace:
    #0 /usr/local/ispconfig/server/lib/app.inc.php(46): db->__construct()
    #1 /usr/local/ispconfig/server/lib/app.inc.php(208): app->__construct()
    #2 /tmp/ispconfig3-stable-3.1-e2465bd7a2d324259c3c1dae00dfca8c2535edcc/install/uninstall.php(38): require_once('/usr/local/ispc...')
    #3 {main}
      thrown in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 79
    
    Any help is greatly appreciated
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not run uninstall, you will not be able to reinstall ispconfig on that system!

    To fix the issue, go through the Ubuntu 18.04 perfect server tutorial to install missing packages. Then run an ispconfig update with reconfigure services = yes.
     
  3. Chris H

    Chris H New Member

    Thank you for the quick reply I went through and installed the packages from the 18.04 tutorial and while I can now access the control panel the sites are still not loading. So that is some progress at least.
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    Do make sure you reinstall and reconfigure services as @till said, and in the control panel, go to tools -> resync and resync everything. If sites still do not load, check error logs.
     
  5. Chris H

    Chris H New Member

    Changing the PHP to FAST-CGI for the sites are making them load again. Roundcube is not working still. I tried downloading the packages again but that didnt do anything. The config files that need to be edited are fine. I get a 500 error trying to go to greatmoon.net/roundcube
     
  6. Chris H

    Chris H New Member

    Here is the roundcube error log

    Code:
      thrown in /usr/share/roundcube/program/lib/Roundcube/html.php on line 357
    [26-Sep-2018 13:17:25 -0700]: PHP Error: Failed to load plugin file /var/lib/roundcube/plugins/filters/filters.php in /usr/share/roundcube/program/lib/Roundcube/rcube_$
    [26-Sep-2018 13:17:25 -0700]: PHP Error: Failed to load plugin file /var/lib/roundcube/plugins/sieverules/sieverules.php in /usr/share/roundcube/program/lib/Roundcube/$
    [26-Sep-2018 13:17:25 America/Los_Angeles] PHP Fatal error:  Uncaught Error: Class 'DOMDocument' not found in /usr/share/roundcube/program/lib/Roundcube/html.php:357
    Stack trace:
    #0 /usr/share/roundcube/program/include/rcmail_output_html.php(905): html::parse_attrib_string('condition="conf...')
    #1 /usr/share/roundcube/program/include/rcmail_output_html.php(633): rcmail_output_html->parse_conditions('<roundcube:obje...')
    #2 /usr/share/roundcube/program/include/rcmail_output_html.php(488): rcmail_output_html->parse('login', false)
    #3 /usr/share/roundcube/index.php(248): rcmail_output_html->send('login')
    #4 {main}
      thrown in /usr/share/roundcube/program/lib/Roundcube/html.php on line 357
    [26-Sep-2018 13:20:53 -0700]: PHP Error: Failed to load plugin file /var/lib/roundcube/plugins/filters/filters.php in /usr/share/roundcube/program/lib/Roundcube/rcube_$
    [26-Sep-2018 13:20:53 -0700]: PHP Error: Failed to load plugin file /var/lib/roundcube/plugins/sieverules/sieverules.php in /usr/share/roundcube/program/lib/Roundcube/$
    [26-Sep-2018 13:20:53 America/Los_Angeles] PHP Fatal error:  Uncaught Error: Class 'DOMDocument' not found in /usr/share/roundcube/program/lib/Roundcube/html.php:357
    Stack trace:
    #0 /usr/share/roundcube/program/include/rcmail_output_html.php(905): html::parse_attrib_string('condition="conf...')
    #1 /usr/share/roundcube/program/include/rcmail_output_html.php(633): rcmail_output_html->parse_conditions('<roundcube:obje...')
    #2 /usr/share/roundcube/program/include/rcmail_output_html.php(488): rcmail_output_html->parse('login', false)
    #3 /usr/share/roundcube/index.php(248): rcmail_output_html->send('login')
    #4 {main}
      thrown in /usr/share/roundcube/program/lib/Roundcube/html.php on line 357
    [26-Sep-2018 13:21:01 -0700]: PHP Error: Failed to load plugin file /var/lib/roundcube/plugins/filters/filters.php in /usr/share/roundcube/program/lib/Roundcube/rcube_$
    [26-Sep-2018 13:21:01 -0700]: PHP Error: Failed to load plugin file /var/lib/roundcube/plugins/sieverules/sieverules.php in /usr/share/roundcube/program/lib/Roundcube/$
    [26-Sep-2018 13:21:01 America/Los_Angeles] PHP Fatal error:  Uncaught Error: Class 'DOMDocument' not found in /usr/share/roundcube/program/lib/Roundcube/html.php:357
    Stack trace:
    #0 /usr/share/roundcube/program/include/rcmail_output_html.php(905): html::parse_attrib_string('condition="conf...')
    #1 /usr/share/roundcube/program/include/rcmail_output_html.php(633): rcmail_output_html->parse_conditions('<roundcube:obje...')
    #2 /usr/share/roundcube/program/include/rcmail_output_html.php(488): rcmail_output_html->parse('login', false)
    #3 /usr/share/roundcube/index.php(248): rcmail_output_html->send('login')
    #4 {main}
      thrown in /usr/share/roundcube/program/lib/Roundcube/html.php on line 357
    
     
  7. Chris H

    Chris H New Member

    The files that it says it fails to load are there so I wonder if there is a permissions issue?
     
  8. Jesse Norell

    Jesse Norell Well-Known Member

    Looks like that is in dom.so from php#.#-xml package, I'm guessing maybe php7.1-xml or php7.2-xml. You might run through the ubuntu 18 perfect server tutorial again and make sure you got all packages installed.

    Code:
    # grep -R DOMDocument /usr/lib/php
    Binary file /usr/lib/php/20170718/dom.so matches
    Binary file /usr/lib/php/20151012/dom.so matches
    Binary file /usr/lib/php/20160303/dom.so matches
    Binary file /usr/lib/php/20180731/dom.so matches
    Binary file /usr/lib/php/20131226/dom.so matches
    
    # dpkg -S /usr/lib/php/*/dom.so
    php5.6-xml: /usr/lib/php/20131226/dom.so
    php7.0-xml: /usr/lib/php/20151012/dom.so
    php7.1-xml: /usr/lib/php/20160303/dom.so
    php7.2-xml: /usr/lib/php/20170718/dom.so
    php7.3-xml: /usr/lib/php/20180731/dom.so
    
     

Share This Page