Website with dedicated IP on ISPConfig3 slave server

Discussion in 'Installation/Configuration' started by Hans, Jun 9, 2011.

  1. Hans

    Hans Moderator ISPConfig Developer

    Hi Till and Falko,

    I have a host (Xen domO) with 3 Xen domains on it (3x domU).
    On the first domU, my iSPConfig3 master server is installed.
    The 2 other domUs are both ISPConfig3 client servers.

    When i add a second IP-address on the master server for a website which needs a dedicated IP for SSL, everything works fine.
    However, when i do the same on one of the ISPConfig slave servers, it doesn't. The vhost file of the site with dedicated IP is ok, but Apache2 shows only "It works".
    I only have this problem on ISPConfig3 slave servers and i am struggling with this problem for quiet some time already.
    I also thought it might be a DNS issue, but i have a block with additionial IPs to choose from. It does not matter which IP i choose for the web. The problem remains.

    Can you reproduce this behavior? I wonder if it's not a bug.

    Hope you can help me out.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am sure that this is not a bug in ISPConfig 3.0.3.3 as I run several slave web servers with dedicated IP addresses here and none of them has such a problem.

    Make sure that you configured the IP address in the vm, so that it shows up in the "ifconfig" command. Then check your dns server and make sure that the Doamina name resolves to the same IP address. Especially check for typos and that you did not forgot to activate auto subdomain www if you want to access the site with www.domain.tld too and not just domain.tld.
     
  3. Hans

    Hans Moderator ISPConfig Developer

    It works now!

    Hi Till,
    Thanks for your reply. In the mean time i found out that the IP was allocated to a different client of my ISP. There was a network conflict and it seems to work now! If this happens the solution is difficult to find. Finally! :)
     

Share This Page