Website shows Apache default page after editing hosts-file

Discussion in 'Installation/Configuration' started by devrookie, Jul 15, 2016.

  1. devrookie

    devrookie New Member

    Hey Guys,
    i do have the following issue on ispconfig 3. I am hosting two websites on my ubuntu development server in the lan which have to communicate with each other and be avaiable for each other.
    That for i added the sites ips and the hostnames to the hosts file and restarted apache. After that the websites show just the apache default site instead of the websites content. If i delete them from the hosts-file it works again.
    What is wrong there, what mistake did i make or which configuration did i miss?

    Thanks in advance for some hints

  2. Johnny Curtis

    Johnny Curtis New Member

    Paste your hosts file here. Let's have a look at it.

    If you go to your ISPConfig control panel, select one of your sites, and under Domain, what do you have set for your IPv4-Address? Is it the same as what you put in your hosts file?
    I'm just stabbing in the dark here because I've never run into this issue. I usually just keep the default asterisk in that field.
    Last edited: Jul 17, 2016
  3. devrookie

    devrookie New Member

    Actually i didn´t set any ip-adress for the Website. It´s the Default value "*".
    My Task is, i am trying to connect two Websites to each other on that Server with an magento extensions which is able to connect magento and joomla.
    When trying to connect the both instances i am getting an DNS-Error on both sites.
    on Joomla site: ERROR: Failed to resolve hostname "" in DNS, on Magento-Site:
    External DNS lookups need to be enabled ...
  4. Jesse Norell

    Jesse Norell Active Member

    Paste the output of 'apachectl -S', and the hosts file as @Johnny Curtis requested.

Share This Page