website showing Apache 2 Test Page

Discussion in 'Installation/Configuration' started by emsjs1, May 9, 2010.

  1. emsjs1

    emsjs1 New Member

    I have added a website in ISPConfig

    There is an include in httpd.conf for /etc/httpd/conf/sites-enabled/

    In httpd.conf, before sites-enabled is called, there are the following entries

    NameVirtualHost *:80
    NameVirtualHost *:443


    Then inside the site's conf, website.com.vhost there is also

    <VirtualHost *:80>

    Originally it was the IP that's there instead of * but it wont work

    Please help I need this fixed as soon as possible. Im running out of ideas
     
  2. till

    till Super Moderator

    Select the IP address instead of * in ispconfig in the website settings. If the IP is not listed there, then add it in the ispconfig system settings.
     
  3. DaleHutch

    DaleHutch New Member

    Greetings!

    I have a similar problem..... I tried the IP suggestion and I'm getting the same results...

    I recently performed Falko's excellent tutorial on "The Perfect Server - Ubuntu 10.04 [ISPConfig 3]"

    Looks like everything installed fine. But I'm having a problem getting the websites to display.

    I entered the different web sites I want this new server to host. I can FTP to the site and upload files. When I try to view the sites using a browser I get the default Apache2 site saying "It Works". I uploaded a generic HTML file onto one of the sites that is a "Hello World" page to know the site is working and I can seem to locate the problem. In looking at the Apache2.conf file all the sites are pointing to the "sites-enabled" directory and my vhost files are in there. I looked in the vhost file and can't see anything out of the ordinary but I'm no expert. Kinda looks like Apache isn't using the "sites-enabled" directory to see what sites are available and using the default.

    Any suggestions?

    Thanks

    Update:

    I restarted Apache...

    It informs me that I don't have VirtualHosts...

    * Restarting web server apache2
    11:53:51 2010] [warn] NameVirtualHost 10.10.0.15:80 has no VirtualHosts
    [Mon May 10 11:53:51 2010] [warn] NameVirtualHost 10.10.5.15:443 has no VirtualHosts
    ... waiting [Mon May 10 11:53:52 2010] [warn] NameVirtualHost 10.10.5.15:80 has no VirtualHosts
    [Mon May 10 11:53:52 2010] [warn] NameVirtualHost 10.10.0.15:443 has no VirtualHosts
     
  4. DaleHutch

    DaleHutch New Member

    FIXED!!!!!!

    Till was correct!


    It wasn't working for me at first because I didn't change the the "*" on the sites as well...


    Thanks Till!


    DH
     
  5. till

    till Super Moderator

    According to the apache warnings, you have not selected the internal IP address in the website settings and the IP was added twice. Please double check that. As you seem to be in a private network, make sure that you selected the internal IP address for thewebsite and not the external IP and that you forwarded the traffic for port 80 from you router to this internal IP that you selected in the website settings.
     

Share This Page