Website mail is not working

Discussion in 'General' started by Robin.k, Aug 29, 2016.

  1. Robin.k

    Robin.k New Member

    Hi,
    I have a website running on a hosting company.
    My website has a contact form. and works perfect on this hosting company.

    Now i have installed the website on my own server debian with ispconfig 3, everything works perfect also the databases etc.
    The only thing that not works is sending mails with the contact form.
    How can i solve this problem?

    Regards Rob
     
    Last edited: Aug 29, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the mail.log file to see which error appears there.
     
  3. Robin.k

    Robin.k New Member

    Hi, I try also to sent a mail from Roundcube (what is running under ispconfig) to my ISP mail adres.

    In the mail.log i get error more than one IP errors like [82.215.xx.xx] :25 connection time out
    It looks that port 25 is blocked by my isp.
    Can i change somewhere the port to another port?

    Regards Rob
     
    Last edited: Aug 30, 2016
  4. Jesse Norell

    Jesse Norell Active Member

    If you have another mail host/service outside your local network, you can set 'relayhost' in ispconfig System Config > Mail settings to relay there. If not and you're trying to run a mail server on your ispconfig box and be able to email anywhere, then no, you're out of luck, as sending mail will require port 25 to be open.
     
  5. Robin.k

    Robin.k New Member

    Hi, Yes, i have another mail host/service outside my local network, and i have try this in ispconfig System Config > Mail settings to relay.
    But no succes. Are these setting correct? Are there also other things to configure?

    Regards Rob

    [​IMG]
     
  6. Jesse Norell

    Jesse Norell Active Member

    For the relayhost, try mail.antagonist.nl:587 (assuming port 587 is remote port you want to use).
     
  7. Robin.k

    Robin.k New Member

    Hi, thanks a lot, now i can send mails with Roundcube.
    The only think dat not works is sending mail from a website that runs under ispconfig.
    This mail form. uses port 25 and i cannot change is, how to solve this problem?

    Thanks Jesse for your replay
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess must have disabled the local postfix instance then as postfix is always listening on localhost port 25, it does not matter if you use an external relay server for that.
     
  9. Robin.k

    Robin.k New Member

    Thanks Tiil for you replay.

    Where can i enable/disable local postfix?

    Regards Rob
     
  10. Robin.k

    Robin.k New Member

    Hello, problem solved. The free domain with the DNS settings from .tk dit not work properly. I chanced to a domain from godaddy, and it is now working.
     

Share This Page