Website location problem

Discussion in 'Installation/Configuration' started by kcjones, Feb 27, 2009.

  1. kcjones

    kcjones New Member

    I just installed ubuntu 8.10 server and ISPConfig 2.2.29. I'm new to the linux environment, but everything seemed to go ok. I set up a reseller, client and web site (call it www.example.com), but have a couple of basic problems.

    First, when I launch example.com, the web server picks up the index.html file in the web root - that is, in /var/www - instead of going to /var/www/web6/web, as it should. There is a symbolic link in /var/www for www.example.com which points to /var/www/web6/web.

    Second, initially, I was able to get into mail config. Then I installed uebimaiu mail. Now I can't log in at all. It accepts the user@example.com user and password, thinks for moment, then fails. Is is true that there must be mail waiting before you can initially log in? I did send mail to this account from another mail account, and the mail was not returned, but there seems to be no sign of it on the server.

    Thanks for any help with this.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you follow exactly the perfect server guide for ubuntu 8.10 to install your server?
     
  3. kcjones

    kcjones New Member

    Yes, I followed the perfect server guide exactly. Most things seem to work now, like proftp, ssh, mysql, and ispconfig. Between my posting and your reply, mail started to behave a little better - I can log onto the mail system now, though I don't seem to be able to send or receive mail yet.

    The main issue for me is still the web site problem. Any help getting this working would be much appreciated.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the last 80 - 100 lines from the apache2.conf file.
     
  5. kcjones

    kcjones New Member

    The end of the apache2.conf file follows below.

    Is seems that the problem has something to do with the Vhosts_ispconfig.conf, which is supposed to be included by apache2 at the end of the config file. When I first looked at the /etc/apache2/vhosts directory it contained an empty Vhosts_ispconfig.conf and dozens of files like Vhosts_ispconfig.conf_27-02-09_21-40-22. I renamed the last file to be Vhosts_ispconfig.conf, restarted some things (don't remember what) and suddenly things worked much better. :) However, the Vhosts_ispconfig.conf is never updated, even when adding new Sites, which just creates another file like Vhosts_ispconfig.conf_27-02-09_21-40-22. And if I run /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php the Vhosts_ispconfig.conf file is renamed Vhosts_ispconfig.conf<current date&time>, and the is no Vhosts_ispconfig.conf file left at all. Obviously, this is the source of the problem. I saw several other posts on the forum that talked about this, but was not able to see how to resolve it.

    It appears as though this is tied into PHP as well, which does not appear to be running. I (foolishly?) changed a line in /home/admispconfig/ispconfig/lib/config.inc.php to read
    $go_info["server"]["apache2_php"] = 'suphp'; which only made matters worse. :(





    # Include of directories ignores editors' and dpkg's backup files,
    # see README.Debian for details.

    # Include generic snippets of statements
    Include /etc/apache2/conf.d/

    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/

    <Directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

    <Directory /var/www/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /var/www/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /var/www/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
     
  6. kcjones

    kcjones New Member

    I reinstalled PHP/Ruby/Python from step 17 on page 6 of the Perfect Server guide. That seemed to fix the Vhosts_ispconfig.conf problem. It now updates properly and I can add new sites from ISPConfig. Also, it no longer leaves files like Vhosts_ispconfig.conf_27-02-09_21-40-22 lying around.

    However, I still can't send or receive email with the uebimiau mail system.

    Also, I have to logon using a name like web12_username@example.com, instead of simply username@example.com. Same for the user web site: the address example.com/~username is rejected but example.com/~web12_username works. This doesn't seem right.

    Thanks
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please atke a look in the mail log and post the errors that you get there when you send a mail with uebimiau.

    Thats absolutely correct. There is no such address as example.com/~web12_username in ispconfig as usernames are web12_username and not just username
     
  8. kcjones

    kcjones New Member

    Thanks, till, the mail log had some useful information in it. For outgoing mail, it seems like the connection to the remote mail system was rejected because my test server is running behind a router/firewall that has a dynamic IP address. Both my local ISP and Windows Hotmail rejected the connection. Gmail, however, accepted it. So it appears that outgoing mail is working.

    Incoming mail is still a problem. After I remembered to forward port 25 from the router to my server, postfix started receiving mail. :rolleyes: However, the mail is still not reaching uebimiau. The following log message after a send from Gmail is typical:

    The email bounced back to gmail which reported:

    Another problem I found in the log is that it seems that every ten minutes, mail wakes up and tries to resend some old mail from a day or so ago. It always fails because it is being rejected for the reasons above. How do I stop this or prevent it? Does the following have anything to do with it?

    Thanks again. :)
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Add a co-domain tertiarygrid.com withe empty hostname field to the website www.tertiarygrid.com and recreate the ssl certificates for postfix as described in the perfect setup guide.
     
  10. kcjones

    kcjones New Member

    Thanks, till, looks like adding the co-domain worked. :)

    The final problem, as described above has to do with continuous retries (sending to an external address) every 10 minutes. The send fails for the reasons discussed earlier in the post (dynamic IP not accepted), which is fair enough. However, the retries just keep happening. It begins with a line in the mail log like the following:

    It looks like the qmgr is spooling these old messages and attempting to resend them every 10 minutes. Is there a way to turn off the retries or flush the queue?

    Thanks.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    you can list the mails in the queue with the command:

    postqueue -p

    and remove emails from the queue with the command postsuper
     
  12. kcjones

    kcjones New Member

    Thanks, till, that did the trick. I have a fully functioning mail system now. :)
     

Share This Page