Website harddisk quota dont work!!

Discussion in 'Installation/Configuration' started by nackgr, Dec 28, 2012.

  1. nackgr

    nackgr New Member

    Hello

    I have isp3 centos nginx .. and my Website harddisk quota dont work !! what to check
     
  2. falko

    falko Super Moderator

    What's the output of
    Code:
    repquota -avug
    ?
     
  3. nackgr

    nackgr New Member

    did nothing
     
  4. till

    till Super Moderator

    Is this a virtual server?
    Did you configure quota in /etc/fstab as described in the perfect setup guide?
     
  5. nackgr

    nackgr New Member

    hello


    thats how my fstab looks ! i think i forgot something there!
    Code:
    proc /proc proc defaults 0 0
    none /dev/pts devpts gid=5,mode=620 0 0 
    /dev/md0 none swap sw 0 0
    /dev/md1 /boot ext3 defaults 0 0
    /dev/md2 / ext4 defaults 0 0
    tmpfs  /mysqltemp  tmpfs size=2G 0 0
    
     
  6. falko

    falko Super Moderator

    The quota options are missing. Please check the tutorial again.
     
  7. nackgr

    nackgr New Member

    can you please instruct me where to add the code ?that missing at fsab
     
  8. till

    till Super Moderator

    Thats decsribed in the tutorial incl. a example of the fstab file. Open the perfectserver tutorail that you sued to install your server and check the chapter that configures and installs quota.
     
  9. nackgr

    nackgr New Member

    where exactly i must add

    ,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0

    bellow here? ?!?!?!

    proc /proc proc defaults 0 0
    none /dev/pts devpts gid=5,mode=620 0 0
    /dev/md0 none swap sw 0 0
    /dev/md1 /boot ext3 defaults 0 0
    /dev/md2 / ext4 defaults 0 0
    tmpfs /mysqltemp tmpfs size=2G 0 0
     
  10. till

    till Super Moderator

    Change:

    /dev/md2 / ext4 defaults 0 0

    to:

    Code:
    /dev/md2 / ext4 defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 0
     
  11. nackgr

    nackgr New Member

    thanks!!!

    i add the line i used to command repquota -avug


    and return


    [root@host ~]# repquota -avug
    repquota: Cannot open quotafile //aquota.user: No such file or directory
    repquota: Cannot open quotafile //aquota.group: No such file or directory
     
  12. nackgr

    nackgr New Member

    i did that


    mount -o remount /

    quotacheck -avugm
    quotaon -avug

    now works!!! thanks
     

Share This Page