Website disappers when SSL is added

Discussion in 'Installation/Configuration' started by ago2guy, May 19, 2009.

  1. ago2guy

    ago2guy New Member

    I had a site up and running and then decide to add an SSL cert to the site. After going through the process the website now only displays the “It Works” page.
    It does however display the correct website if I enter the IP address but not the domain name.


    It appears that the apache default page is the page I see while requesting the www.domain.tld but it gets that correct site when entering the IP address.

    A dig at the host name server gives the correct IP to domain name translation.

    Thoughts?
     
    Last edited: May 19, 2009
  2. till

    till Super Moderator

    Please make sure that you selected the correct IP address in the website settings in ispconfig and not *, as * can not be used together with SSL certificates with the apache webserver.
     
  3. ago2guy

    ago2guy New Member

    Thanks Till

    Yes, It was a unique IP. I have since dropped the cert and am just trying to get it running again.
    sites-available is correct.

    if I run apache2ctl restart I get
    [warn] VirtualHost 10.0.0.121:80 overlaps with VirtualHost 10.0.0.121:80, the first has precedence, perhaps you need a NameVirtualHost directive

    If I run a2ensite domain.tld I get
    ERROR: Site domain.tld does not exist!

    It reolves to the IP but I get the apache default index.html if I try the www.domain.tld itself.

    As stated this was working before I tried to add a cert on a website with a static exclusive IP address.

    Thoughts?
     
  4. ago2guy

    ago2guy New Member

    Oh No...I think I upset till in the gerneal fourm ... sorry.
     
  5. ago2guy

    ago2guy New Member

    [Tue May 19 18:59:02 2009] [warn] NameVirtualHost 10.0.0.120:443 has no VirtualHosts
    /usr/share/getmail4/getmailcore/baseclasses.py:26: DeprecationWarning: the sets module is deprecated
    import sets
    Error: configuration file /etc/getmail/*.conf does not exist
     
  6. ago2guy

    ago2guy New Member

    Oh man its getting worse

    root@glue:/etc/apache2/sites-available# apache2ctl restart
    [Tue May 19 19:20:05 2009] [warn] NameVirtualHost 10.0.0.120:80 has no VirtualHosts
    [Tue May 19 19:20:05 2009] [warn] NameVirtualHost 10.0.0.120:443 has no VirtualHosts
    [Tue May 19 19:20:05 2009] [warn] NameVirtualHost 10.0.0.121:443 has no VirtualHosts
     
  7. ago2guy

    ago2guy New Member

    Well thats it...now it completely does not work.
    I deleted all ips but two one for ispconfig and one for my domain
    my site will resolve to the IP only

    All because I tried to add an SSL Cert.
     
  8. ago2guy

    ago2guy New Member

    Delete and reinstall

    bummer...not ready for production for sure.

    Thanks
     
  9. till

    till Super Moderator

    Not sure what you did because adding a ssl cert does not cuse any problems on my servers, I'am doing that frequently. I use it in production for over a year without any problems.
     
  10. ago2guy

    ago2guy New Member

    Looks like I am not alone...Read down on this link...same issue

    http://www.howtoforge.com/forums/showthread.php?t=35207


     
    Last edited: May 27, 2009

Share This Page