website creation has no effects on system

Discussion in 'Installation/Configuration' started by sonotone, Mar 29, 2010.

  1. sonotone

    sonotone New Member


    I have to face a problem with ispconfig running on Debian Lenny:

    If i want to crreate a new website or new customer, informations are registered into ispconfig database, but ISPconfig don't creat associated folders in /var/www, and don't add hosts in /etc/apache2/ folder.

    Same prob with mysql, i checked right of ispconfig user and switched it to with all proivileges, but still the same problem.

    The job queue is empty. I don't meet such issues with mail account creation.

    There is nothing significant in ispconfig logs, and i don't know what to do now...

    I've got an error during update process:
    /usr/local/ispconfig/server/scripts/ line 18: syntax error near unexpected token `else'
    /usr/local/ispconfig/server/scripts/ line 18: `else'

    and also when i restart apache, since the update:
    NameVirtualHost has no VirtualHosts

    Thanks for help.
    Last edited: Mar 29, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please do not cahnge this. The permissions that ispconfoig sets during instal are required and correct. The ispconfig user shall not have all priveliges as this might impose security problems on your system.

    Thats ok.

    I guess that the shusers group is missing on your system. Please run:

    groupadd sshusers

    and try to add a new website.
  3. sonotone

    sonotone New Member

    Thanks for answer.

    Just tested to add the sshusers, but it already exist.
    The thing that surprise me, there nothing in the jobqueue, even if i go to check it just after adding a new site.
    just tried to run again /usr/local/ispconfig/server/scripts/ manually, and everything looks ok.

    EDIT: is there a ispconfig actions log somewhere in the system, to check what happpenning?
    EDIT2: ok sorry, found how to activate debug mode...

    Last edited: Mar 29, 2010
  4. sonotone

    sonotone New Member

    Well, i've compared 2 ispconfigs logs.
    The one witch don't works has only thoses lines in loop:
    DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    DEBUG - No Updated records found, starting only the core.
    DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    Where the functionnal installation report actions. I don't have more clues about what goes wrong, but hope i'll find something.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the value in the field "updated" in the record for the non working server in the "server" table of the ispconfig database and what is the highest value of the sys_datalog_id (the last record) in the sys_datalog table?
  6. sonotone

    sonotone New Member

    datalog_id is incremented at 101, and the update status of the server is 140.
    All sys-datalog are "pending".

    I've tested a new action with ispconfig's interface, and the new datalog_id is registered.
    If i understand well, the idea should be to remove datalog_ids, and then fit the serveur update status with the last datalog_id registered?

    Thanks for your time.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Set the update field of the server table to the last datalog_id that was successfully executed on the server, if you dont know it, set it to the current datalog id so that all new actions will get executed.
  8. sonotone

    sonotone New Member

    Thanks, you found the issue. After decrease update status to 102, your application is running well.

    Thanks again and keep the good work.


Share This Page