Website Apache Directives ignored

Discussion in 'Installation/Configuration' started by simonb, Aug 19, 2011.

  1. simonb

    simonb New Member

    I have ISPConfig installed on Ubuntu 10.04 LTS.

    Putting the following line in an .htaccess file works...
    redirect 301 /index.html /alt-index.html
    As expected, the index.html page is redirected to an alternate page.

    However if I remove it from .htaccess and put it in the Web Domain "Apache directives" section it is completely ignored. No redirect takes place.

    The same goes for any other directives I put there.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you waited at least one minute before you test that. The new file has been written when the job has been removed from jobqueue in ispconfig monitor.
  3. simonb

    simonb New Member

    Hi Till,

    Yes, that was what the problem was. I didn't wait for the cron job.

    I also solved a previous problem getting a reverse proxy to work. Any errors in the config mean that it the config just gets silently dropped. I was able to see the errors by running /usr/local/ispconfig/server/ from the command line. Maybe there's an easier way to know if there are errors.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Enable loglevel warn or debug in ispconfig and then take a look at the system log in the ispconfig monitor.

Share This Page