Website and mail files owned by wrong user:group

Discussion in 'General' started by lonerunner, May 26, 2021.

  1. lonerunner

    lonerunner Member

    So i created the website with admin by mistake and now website and files are owned by wrong user:group when i created another website.

    Here are the steps i did:

    Created new account (client14)
    Then instead to login to that account, i created new website using admin account so the website got the owner (web16)
    When i take a look at the folder structure the website folder was created in /var/www/clients/client0/web16
    When i realized i made it with the admin account i deleted the website.
    Then i login to the (client14) account and created the website and now the new website is created in folder /var/www/clients/client14/web17
    But everything in the folder of /var/vmail/website.com and /var/www/clients/client14/web17 is owned by client14:web16

    I tried to change user:group and it won't change the files to client14:web17
    I tried to resync in ispconfig if it is worth something, nope
    When i take a look at the list of groups and users, the web16 doesn't exist and in /etc/passwd file, web17 is tied to the /clients/client14/web17 folder.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That sounds like the correct process.
    Everything under vmail should be owned by vmail:vmail (unless you have 'Use Websites Linux uid for mailbox' setting enabled, which is usually not what you want). The website files sure shouldn't be in the web16 user (which you later said doesn't exist); you sure you didn't check that while the delete/recreate was being made and maybe saw some inconsistent states?
    What command did you run, and error do you get? Note web17 is the user, client14 is the group, so should be "chown web17:client14 whatever....".
    Sounds correct. If you can find a reproducable sequence that causes things to get out of sync, please file an issue in the tracker.
     
  3. lonerunner

    lonerunner Member

    It is checked indeed, What i understood this is only for single server and if i want to include quota space into the user account space

    I haven't seen anything wrong during creation/delete process. The user id in ispconfig is 14, the website id in ispconfig is 17, seems that's ok.


    Code:
    chown -R web17:client14 /var/www/clients/client14/web17/web
    I didn't get any errors, the command works for other clients/websites i transferred.

    maybe i should check some more logs and see if anything caught up as ispconfig log doesn't output anything.
     
  4. lonerunner

    lonerunner Member

    Huh, i just restarted the server, and the user and groups are now in sync.
     

Share This Page