Webserver shows offline but is online

Discussion in 'Installation/Configuration' started by unsichtbare, Aug 12, 2011.

  1. unsichtbare

    unsichtbare Member HowtoForge Supporter

    So I just did a new ISPConfig on Ubuntu 10.04 and (after I fixed the password), I noticed that under Services, the Web-server and BIND-Server shows offline:

    Web-Server:
    Offline
    FTP-Server:
    Online
    SMTP-Server:
    Online
    POP3-Server:
    Online
    BIND-Server:
    Offline
    mySQL-Server:
    Online

    But it is clearly serving websites and at the command line:
    Code:
    [email protected]:/# /etc/init.d/apache2 status
    Apache is running (pid 3582).
    [email protected]:/# /etc/init.d/bind9 restart
     * Stopping domain name service... bind9                                                                                                              [ OK ]
     * Starting domain name service... bind9                                                                                                              [ OK ]
    [email protected]:/# /etc/init.d/bind9 status
     * could not access PID file for bind9
    [email protected]:/# netstat -tap | grep www
    tcp        0      0 *:www                   *:*                     LISTEN      3582/apache2
    [email protected]:/etc/apache2# httpd -t
    httpd: bad user name ${APACHE_RUN_USER}
    
    So what's going on?
     
    Last edited: Aug 12, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    Sometimes there's a delay in updating the Monitoring details. Does it still show these services as offline?
     
  3. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Yes, still offline.

    What about the:

    [email protected]:/etc/apache2# httpd -t
    httpd: bad user name ${APACHE_RUN_USER}
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you apache server listens on localhost too.
     
  5. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Where do I check?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can check that with:

    netstat -tap | grep apache

    or


    netstat -tap | grep http
     
  7. unsichtbare

    unsichtbare Member HowtoForge Supporter

    I apologize; I get a bit rusty between webserver deployments.

    Code:
    [email protected]:~# netstat -tap | grep apache
    tcp        0      0 *:www                   *:*                     LISTEN      1405/apache2
    tcp        0      0 *:https                 *:*                     LISTEN      1405/apache2
    [email protected]:~# netstat -tap | grep http
    tcp        0      0 *:81                    *:*                     LISTEN      1365/ispconfig_http
    tcp        0      0 *:https                 *:*                     LISTEN      1405/apache2
    [email protected]:~#
    
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok. Please post the content of the /etc/hosts file.
     
  9. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Code:
    127.0.0.1       localhost.localdomain
    24.156.37.146   main.azwebdesigns.com   main
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Ă„ndere bitte die Zeile:

    127.0.0.1 localhost.localdomain

    in

    127.0.0.1 localhost localhost.localdomain
     
  11. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Thanks, works perfectly.
     

Share This Page