Webserver (not) online and permissions

Discussion in 'General' started by Rashef, Oct 10, 2012.

  1. Rashef

    Rashef New Member

    Hi guys,

    this morning I found an error message on my ISPConfig3 Monitor page. Webserver is showed as OFFLINE even if the HTTPD service is up and running.

    All the websites are online but I noticed a worrying behavior: I have mostly Wordpress installations and now I'm not able to upload pictures with the integrated uploader anymore. The 755 permission on the "upload" folders, that worked till yesterday, now it's not enough. It works only if I set 775 permission.

    What the h**l did change??????!!!?!?!? :confused:
  2. Rashef

    Rashef New Member

    Ok I solved the problem.
    Some days ago I modified /etc/httpd.conf modifying the "Listen" entry from:

    Listen 80

    Listen public_ip:80
    And the httpd service was restarted last night. Everything was solved changing it back...
  3. Rashef

    Rashef New Member

    Guys, I still have one problem!
    I noticed that one of the Wordpress webiste suddenly is not able to upload files anymore. After some test I realized that now the website is running with user Apache instead of the client user...

    The only difference from other website on the same ISPconfig installation is that some week ago I had to switch this website from FastCGI to mod-PHP because of a plugin.

    What could be the problem?

    thanks a lot
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that you switched from php-fastcgi to mod_php. mod_php does not support different users for websites, so you cant upload files when you use mod_php or you will have to chmod the upload folder to 777 which is qute insecure.
  5. Rashef

    Rashef New Member

    Woah... what a mistake!

Share This Page