Webserver created files have wrong permisions/owner

Discussion in 'General' started by link-m, Feb 3, 2012.

  1. link-m

    link-m New Member

    Hi,
    I run ispconfig several users are on the system and everything is working fine, but...

    Some users have wordpress installed and install plugins via the web interface. This way the webserver creates files on the hard disk in the web directory of the user.
    These files have the ownership of www-data.www-data and not client1.web1 (just an example). As the webserver also creates directories the user is no longer able to delete these webserver created files.

    Has anyone a solution to this problem other than running a cronjob the resets the permission of every file owned by the webserver every now and then?

    As I ran my own selfmade hosting solution I had one apache instance for every user in chroot environment and that way all webserver created files had the correct ownership and permissions. But the ispconfig approach does not allow this, as far as I understand ispconfig... :(


    Cheers,
    Nicki
     
  2. till

    till Super Moderator

    Your website settingsare wrong. For CMS Systems like joomla, wordpress, typo3 etc. the following settings are required (as described in the manual):

    php mode: php-fcgi
    Suexec: on
     
  3. link-m

    link-m New Member

    Is there an easy way to define this a default for all new websites?
     
  4. till

    till Super Moderator

    This is the default in current ispconfig 3 releases.
     

Share This Page