webpage won't load, Apache Debian /etc/apache2/sites-available/default file seems OK

Discussion in 'Server Operation' started by rjamesd, Aug 24, 2007.

  1. rjamesd

    rjamesd New Member

    I have a Debian 4.0 Etch Linux server, called rockstar. My CGI Perl script files are not running and displaying in the browser.

    For example...


    ...displays the following in the IceWeasel browser:

    Not Found

    The requested URL /cgi-bin/bugzillla/ was not found on this server.
    Apache/2.2.3 (Debian) mod_python/3.2.10 Python/2.4.4 PHP/4.4.4-8+etch4 mod_perl/2.0.2 Perl/v5.8.8 Server at rockstar Port 80

    /var/log/apache2/error.log shows an entry for the above attempted access:

    [Mon Aug 20 10:19:10 2007] [error] [client] File does not exist: /var/www/bugzilla, referer: http://rockstar/cgi-bin/bugzilla/index.cgi

    But Apache shouldn't attempt to go to /var/www/bugzilla because I have set up a re-direct to /usr/lib/cgi-bin/ (using ScriptAlias directive ) in /etc/apache2/sites-available/default :-

    NameVirtualHost *
    <VirtualHost *>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin/">
    AllowOverride None
    Options ExecCGI -MultiViews FollowSymLinks
    Order allow,deny
    Allow from all

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined
    ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from ::1/128


    Also, sr/lib/cgi-bin/bugzilla contains the index.cgi file that I expect to run and display HTML at the browser :-

    rockstar:/usr/lib/cgi-bin/bugzilla# ls
    attachment.cgi editparams.cgi report.cgi
    buglist.cgi editproducts.cgi reports.cgi
    bugzilla.html editsettings.cgi request.cgi
    chart.cgi editusers.cgi sanitycheck.cgi
    colchange.cgi editvalues.cgi show_activity.cgi
    config.cgi editversions.cgi showattachment.cgi
    createaccount.cgi editwhines.cgi show_bug.cgi
    describecomponents.cgi enter_bug.cgi showdependencygraph.cgi
    describekeywords.cgi index.cgi showdependencytree.cgi
    duplicates.cgi long_list.cgi sidebar.cgi
    editclassifications.cgi page.cgi summarize_time.cgi
    editcomponents.cgi post_bug.cgi testagent.cgi
    editflagtypes.cgi process_bug.cgi token.cgi
    editgroups.cgi query.cgi userprefs.cgi
    editkeywords.cgi quips.cgi votes.cgi
    editmilestones.cgi relogin.cgi xml.cgi

    What's wrong?

    Also, note that page requests for http://rockstar/ do work - they go to /var/www/index.html
  2. rjamesd

    rjamesd New Member

Share This Page