Webpage can't found after installing ISPConfig

Discussion in 'Installation/Configuration' started by docdries, Jul 30, 2008.

  1. docdries

    docdries New Member HowtoForge Supporter

    Hello to all,

    I have followed the great howto The Perfect Setup - Debian Etch I install it on my laptop in VMware. It seems to works, i can reach the webpage that apache provided after installing. The FTP server works also, so i think that the others will works.

    Than I installed ISPConfig-2.2.24, and it seems that the install goed fine, (i wasn't sure what IP i must enter wen the setup it asked so i fill in my LAN IP). After the setup i was tried to login on "https://www.mydomainname:81" but i get webpage not found. I thought maybe it was the wrong IP and run the uninstall from ISPConfig and run setup again. When asked for the IP i give my WAN IP, and gues what, i can't reach my "https://www.mydomainname:81" either.

    Well I must say that Linux is new for me, but will learn when is possible. Is there somebody who can help me out please?
     
  2. commentator

    commentator New Member

  3. docdries

    docdries New Member HowtoForge Supporter

    Thanks, I thougt also and tried it before postid here, neither doesnt works.
    When I tried 'http://mydomainname' I get the standard index.html from apache. So i don't think that is the problem, I have run a website before.

    Tnx anyway for your reply.
     
    Last edited: Jul 30, 2008
  4. commentator

    commentator New Member

    login as root

    /etc/init.d/ispconfig_server start

    see errors?
    or do y ou have to fill in a password?
     
  5. docdries

    docdries New Member HowtoForge Supporter

    server1:~# /etc/init.d/ispconfig_server start
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd (pid 2575) already running
    FreshClam is already running!
    ISPConfig system is now up and running!
    server1:~#


    As you can see ISPConfig is already running.

    I was thinking again and also was checking my router, and have port 81 open for HTTPS. My firewall in this windows pc has also open port 81 for HTTPS. So I gues that we ca rule out also.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    please post the output of:

    netstat -tap | grep ispconfig

    and:

    iptables -L
     
  7. docdries

    docdries New Member HowtoForge Supporter

    Here the output:
    server1:~# netstat -tap | grep ispconfig
    tcp 0 0 *:81 *:* LISTEN 2561/ispconfig_http
    server1:~# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    server1:~#

    As I ask in my start tread, there is a problem that I didn't know what kind of IP adres I must give in de setup of ISPConfig is that my LAN IP or is it the WAN IP? I tried first my LAN IP what is 192.168.1.130 when this not worked I tried my WAN IP also with the same result.

    Greets en tnx for your time.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to use the LAN IP. You should be able to access ISPConfig with:

    https://LANIP:81/

    Replace LANIP with the Lan IP of your server.
     
  9. docdries

    docdries New Member HowtoForge Supporter

    Nope can't find that page, I will format my other server and install it live, in stead of on VMware. I have enough seen to decide that my server will be a Debian server. :)

    Will let you know here how that goes.

    Till than I will keep this image.
     
  10. docdries

    docdries New Member HowtoForge Supporter

    To be sure: When I install ISPConfig at the end there are somethings to fill in:
    Answer it like the following:
    localhost
    root
    typeinhereyourmysqlpassword
    db_ispconfig (it´s the default)
    typeinhereyourserverIP like IS this my LAN IP or WAN IP??
     
  11. Hans

    Hans Moderator ISPConfig Developer

    You have to use the Internal IP-address of your servers NIC within your LAN.
    Not the IP-address of your WAN.

    You can check this IP-address with executing the command: ifconfig.
     
    Last edited: Jul 31, 2008
  12. docdries

    docdries New Member HowtoForge Supporter

    Well I don't get it anymore, I did a fresh install with the help from the great howto Perfect setup Debian Etch, and not on VMware. It run's smootly and via 'http://www.mydomainname.nl' is the standard Apache 2 page to see.

    After the install I installed ISPConfig, and I'm sure that everything goes well in that install. Afterwards on my laptop (with Vista) I can not reach 'https://www.mydomainname.nl:81' or 'https://LAN-IP:81'. I checked everything but can't find anything wrong.

    Who can help me out?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be a problem with a firewall on your vista computer or on a router / firewall in your network.
     
  14. docdries

    docdries New Member HowtoForge Supporter

    Yeah that's what I thought to, but I tried it with vista's firewall disabled, in my router, I have opend port 80 for HTTP and 81 for HTTPS both for my server LAN IP 192.168.1.130 In explorer I have TLS 1.0 and SSL 3.0 proper set. Have you any ideas that will me helped futher please let me know.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try a different internet browser. e.g. firefox. IE gives somtimes wrong or no error messages, e.g. ehrn the SSL certificate is corrupt.
     
  16. docdries

    docdries New Member HowtoForge Supporter

    hmmm that is something wel I was thinking and it hit me, I have an old pc on the attic with SuSe on it. Well first I tried Firefox and this is what it give me:
    Could not establish an encrypted connection because certificate presented by "www.mydomain.nl" has an invalid signature.

    Than I tried Konqueror and that give me: The server certificate failed the authenticity test (www.mydomain.nl) It give me three options details continu and cancel. Ofcource I was hit the button details, and made a screenprint, I'm not sure is it allowed to post it here? Than I hit the button continu and yes yes finaly the login screen appears.

    But still there is something not right so what to do? Where did I go wrong?

    Please some advise.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    It is normal that you get an error because its a self signed certificate. Just slecet to accept the certificate.

    If there is no option to accept the certificate or in case of IE you get just a blank page, then the certificate is corrupted and you will have to create a new one as described here:

    http://www.howtoforge.com/forums/showpost.php?p=358&postcount=4
     
  18. docdries

    docdries New Member HowtoForge Supporter

    Well indeed this did it, finaly it works! And even in IE it works so now a can play around, again thanks for yor time and help.

    Greetz from here.
     
  19. happz

    happz New Member

    Not an expert but you say you install in VMware

    Please descripe what you did. did you install the linux via VMware running in a windows laptop? I ask because if you did you will need to set the NIC use the laptop's IP or to bridge to the network. Now to answer your question about IP. when asked about ip the answer is you lan ip. Sorry to ask so many question but are you in a business WAN or home setup?
     
  20. docdries

    docdries New Member HowtoForge Supporter

    Yes first time I did a install on my laptop (with Windows Vista) in VMware, VMware was bridged. Last try (and working now) was on a standalone machine, wich will be my server. My WAN IP is my home WAN, I have this IP number now for a year of so.

    I'm glad that everything works now, I have only one question for now, there are many great Howtos, but they are practically all abot to install this or that. Are there also howtos how to configuring some things? e.g. FTP or Postfix enz.
     

Share This Page