Webmail / Webftp Issue

Discussion in 'Installation/Configuration' started by Dy0nisus, Feb 8, 2007.

  1. Dy0nisus

    Dy0nisus New Member

    Hi guys!

    I got two little problems.

    1st webmail:

    It's the webmail - package from ISPConfig website. I can read emails without any problems. But sendig a mail causes this error:

    Code:
    FEHLER: Diese Email konnte nicht versandt werden.
    
    SMTP Error: Recipient not accepted. Verify your relay rules
    
    sending mail with a normal mail - client works.

    according to this issue. is use ssl - secured mail transfer, but the certificate is for "localhost" is there anyway of changing this without building a new cert?

    2nd problem webftp:

    it simply doesnt work. after logging ist this error:

    Code:
    Verbindung fehlgeshlagen mit Server localhost 
    then i looked at the server - status: ftp is down ???

    using a ftp client everything works. (only the login takes up to 15 sekonds).

    any ideas?

    greetings
    Dennis
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output aof:

    netstat -tap

    and:

    postconf -n | grep mynetworks
     
  3. Dy0nisus

    Dy0nisus New Member

    output of nestat -tap

    Code:
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:24674                 *:*                     LISTEN     28460/soldatserver
    tcp        0      0 *:51234                 *:*                     LISTEN     19631/server_linux
    tcp        0      0 *:11111                 *:*                     LISTEN     19631/server_linux
    tcp        0      0 *:3784                  *:*                     LISTEN     22053/ventrilo_srv
    tcp        0      0 *:3785                  *:*                     LISTEN     11100/ventrilo_srv
    tcp        0      0 *:24074                 *:*                     LISTEN     28490/soldatserver
    tcp        0      0 *:24874                 *:*                     LISTEN     28475/soldatserver
    tcp        0      0 localhost:mysql         *:*                     LISTEN     25642/mysqld
    tcp        0      0 *:24684                 *:*                     LISTEN     28460/soldatserver
    tcp        0      0 h740154.serverkomp:3343 *:*                     LISTEN     15673/eggdrop
    tcp        0      0 *:81                    *:*                     LISTEN     1188/ispconfig_http
    tcp        0      0 *:24274                 *:*                     LISTEN     28445/soldatserver
    tcp        0      0 *:24084                 *:*                     LISTEN     28490/soldatserver
    tcp        0      0 *:24884                 *:*                     LISTEN     28475/soldatserver
    tcp        0      0 *:50324                 *:*                     LISTEN     28558/psybnc
    tcp        0      0 h740154.serverko:domain *:*                     LISTEN     14236/named
    tcp        0      0 localhost:domain        *:*                     LISTEN     14236/named
    tcp        0      0 *:ftp                   *:*                     LISTEN     30370/proftpd: (acc
    tcp        0      0 *:smtp                  *:*                     LISTEN     15355/master
    tcp        0      0 localhost:953           *:*                     LISTEN     14236/named
    tcp        0      0 *:24284                 *:*                     LISTEN     28445/soldatserver
    tcp        0      0 *:9119                  *:*                     LISTEN     29574/sbnc
    tcp        0      0 h740154.serverkom:46019 quakenet2.underwor:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:47147 quakenet2.underwor:6668 VERBUNDEN  28558/psybnc
    tcp        0  46268 h740154.serverkom:24884 glc122.internetdsl:1164 FIN_WAIT1  -
    tcp        0      0 h740154.serverkomp:3784 84.191.127.167:1294     VERBUNDEN  22053/ventrilo_srv
    tcp        0      0 h740154.serverkom:24884 221.145.56.152:knetd    TIME_WAIT  -
    tcp        0      0 h740154.serverkom:34659 quakenet2.underwor:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:50324 e177169241.adsl.al:4866 VERBUNDEN  28558/psybnc
    tcp        0  21780 h740154.serverkom:24884 dsl.dynamic8510023:1601 VERBUNDEN  -
    tcp        0      0 h740154.serverkom:51882 wineasy.se.quakene:ircd VERBUNDEN  28558/psybnc
    tcp        0      0 h740154.serverkom:24284 a84-230-93-167.eli:1096 TIME_WAIT  -
    tcp        0      0 h740154.serverkom:24284 a84-230-93-167.eli:1095 TIME_WAIT  -
    tcp        0      0 h740154.serverkom:24284 a84-230-93-167.el:rootd TIME_WAIT  -
    tcp        0      0 h740154.serverkom:24284 a84-230-93-167.e:proofd TIME_WAIT  -
    tcp        0      0 h740154.serverkom:52817 82.211.16.16:6668       VERBUNDEN  28558/psybnc
    tcp        0      0 h740154.serverkom:35921 irc.multiplay.co.u:6668 VERBUNDEN  15673/eggdrop
    tcp        0      0 h740154.serverkomp:3784 port-212-202-41-23:3231 VERBUNDEN  22053/ventrilo_srv
    tcp        0      0 h740154.serverkom:58043 irc.multiplay.co.u:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:24674 dsl-kjnbrasgw1-ff3:1047 VERBUNDEN  28460/soldatserver
    tcp        0      0 h740154.serverkom:24874 dsl-kjnbrasgw1-ff3:1049 VERBUNDEN  28475/soldatserver
    tcp        0      0 h740154.serverkom:34782 quakenet.underworl:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:24074 dsl-kjnbrasgw1-ff3:1051 VERBUNDEN  28490/soldatserver
    tcp        0      0 h740154.serverkom:24274 dsl-kjnbrasgw1-ff3:1045 VERBUNDEN  28445/soldatserver
    tcp        0      0 h740154.serverkomp:3784 87.160.229.40:64683     VERBUNDEN  22053/ventrilo_srv
    tcp        0      0 h740154.serverkom:36237 quakenet.xs4all.nl:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:40096 66.225.232.72.reve:7084 TIME_WAIT  -
    tcp        0      0 h740154.serverkomp:3784 port-212-202-41-23:3231 VERBUNDEN  22053/ventrilo_srv
    tcp        0     33 h740154.serverkom:58043 irc.multiplay.co.u:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:24674 dsl-kjnbrasgw1-ff3:1047 VERBUNDEN  28460/soldatserver
    tcp        0     42 h740154.serverkom:24874 dsl-kjnbrasgw1-ff3:1049 VERBUNDEN  28475/soldatserver
    tcp        0      0 h740154.serverkom:34782 quakenet.underworl:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:24074 dsl-kjnbrasgw1-ff3:1051 VERBUNDEN  28490/soldatserver
    tcp        0      0 h740154.serverkom:24274 dsl-kjnbrasgw1-ff3:1045 VERBUNDEN  28445/soldatserver
    tcp        0      0 h740154.serverkomp:3784 87.160.229.40:64683     VERBUNDEN  22053/ventrilo_srv
    tcp        0      0 h740154.serverkom:36237 quakenet.xs4all.nl:ircd VERBUNDEN  29574/sbnc
    tcp        0      0 h740154.serverkom:40099 66.225.232.72.reve:7084 TIME_WAIT  -
    tcp        0      0 h740154.serverkom:40098 66.225.232.72.reve:7084 TIME_WAIT  -
    tcp        0      0 h740154.serverkom:40097 66.225.232.72.reve:7084 TIME_WAIT  -
    tcp        0      0 h740154.serverkom:40096 66.225.232.72.reve:7084 TIME_WAIT  -
    tcp        0      0 h740154.serverkom:40095 66.225.232.72.reve:7084 TIME_WAIT  -
    tcp        0      0 h740154.serverkom:40094 66.225.232.72.reve:7084 TIME_WAIT  -
    tcp6       0      0 *:imaps                 *:*                     LISTEN     894/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     915/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     902/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     881/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     12900/apache2
    tcp6       0      0 *:auth                  *:*                     LISTEN     15242/oidentd
    tcp6       0      0 *:ssh                   *:*                     LISTEN     1130/sshd
    tcp6       0      0 *:smtp                  *:*                     LISTEN     15355/master
    tcp6       0      0 localhost:953           *:*                     LISTEN     14236/named
    tcp6       0      0 *:https                 *:*                     LISTEN     12900/apache2
    
    output of postconf -n | grep mynetworks

    Code:
    mynetworks = 127.0.0.0/8
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    
     
  4. Dy0nisus

    Dy0nisus New Member

    no ideas? i realy need to get this working :(
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the content of /etc/hosts
     
  6. Dy0nisus

    Dy0nisus New Member

    Code:
    127.0.0.1       localhost
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    
    85.214.35.115   h740154.serverkompetenz.net h740154
    
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please change
    Code:
    127.0.0.1       localhost
    to
    Code:
    127.0.0.1       localhost.localdomain localhost
     
  8. Dy0nisus

    Dy0nisus New Member

    done ...

    webmail still won't send email ...

    webftp still not works :(
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please try to comment out these lines in /etc/hosts:

     
  10. Dy0nisus

    Dy0nisus New Member

    Thank you!

    It works ...

    but why?
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    By following Till's advice you have disabled IPv6 support which seems to have caused the problem.
     
  12. Dy0nisus

    Dy0nisus New Member

    i know what i did ... but i do not understand why this solves the problem ...
     
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I cant tell you the exact reason, its somehow that all services are listening on IPv6 localhost only and not on IPv4 localhost when the IPv6 localhost definition is in /etc/hosts. I had this problem on a server and it took me some time to figure this out.
     

Share This Page