webmail url trailing slash

Discussion in 'Installation/Configuration' started by hairydog2, Nov 2, 2005.

  1. hairydog2

    hairydog2 New Member

    All seems to be working well with ISPConfig - but I have noticed an odd thing with the webmail login.

    https://www.domain.com:81/webmail fails to do anything but
    https://www.domain.com:81/webmail/ works. I thought that apache added the missing / if it was needed, so why not here?

    I've also noticed that on one of the hosted websites, there is a directory whose index page is index.php but going to that directory doesn't open the index page, even thought index.php is listed as an index file name.

    I wonder if these two are linked problems. Whether or not, I'd appreciate any suggestions!
  2. falko

    falko Super Moderator ISPConfig Developer

  3. hairydog2

    hairydog2 New Member

    Yes. I have ao add more words here to make the message save, but the answer is just "yes".
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /root/ispconfig/httpd/conf/httpd.conf as ServerName? Is it www.domain.com?
    Last edited: Nov 2, 2005
  5. hairydog2

    hairydog2 New Member

    I think you may have identified the problem.

    The actual address I'm using is https://hosting.hairydog.co.uk:81/webmail

    There is no site at http://hosting.hairydog.co.uk yet, just the default index.html

    The plan is to have a completely different site at http://hairydog.co.uk and the same at http://www.hairydog.co.uk (though the DNS for that points somewhere else at present)

    The ServerName was set as hairydog.co.uk but I've changed it to hosting.hairydog.co.uk - and that seems to have fixed the problem.

    Thank you for your help.

Share This Page