webmail URL problems

Discussion in 'General' started by rayit, Nov 2, 2005.

  1. rayit

    rayit New Member

    I have 3 servers now 2 42go servers and 1 ispconfig server.

    ns1.rayit.com
    ns2.rayit.com
    ns3.rayit.com

    If I go to https://ns1.rayit.com:81/webmail

    It changes to https://rayit.com:81/webmail/ :eek: and this is the other server (ns2.rayit.com) not the ns1.
    So I can not login with users from ns1.

    Is there a way to solve this :confused: ?

    many thanks


    Raymond
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does ns1.rayit.com resolve correctly to the right system?
     
  3. rayit

    rayit New Member

    resolv

    If I do a ping ns1 resolves to the right system, alse there are no problems with using ISPConfig.

    H:\>ping ns1.rayit.com

    Pinging ns1.rayit.com [80.100.251.30] with 32 bytes o

    Reply from 80.100.251.30: bytes=32 time=112ms TTL=42
    Reply from 80.100.251.30: bytes=32 time=115ms TTL=42

    H:\>nslookup ns1.rayit.com
    Server: castor.krk.medt
    Address: 144.15.73.31

    Non-authoritative answer
    Name: ns1.rayit.com
    Address: 80.100.251.30
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /root/42go/httpd/conf/httpd.conf as ServerName? Is it ns1.rayit.com?
     
  5. rayit

    rayit New Member

  6. rayit

    rayit New Member

    Now problem users can not login.

    Not possible to login to webmail :confused: .

    I saw same problem in other topic, tried serveral but still can not login with email address and password :eek:

    See logs below, do you have suggestions???



    Nov 2 21:14:36 ns3 ipop3d[1219]: pop3 service init from 127.0.0.1
    Nov 2 21:14:36 ns3 ipop3d[1219]: Command stream end of file while reading line user=??? host=localhost.localdomain [127.0.0.1]

    ns3:/home/www/web1# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 localhost ESMTP Postfix (Debian/GNU)
    ehlo localhost
    250-localhost
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you send an email to the user before you tried to login? The Maildir or mbox is created when the first email arrives.
     
  8. rayit

    rayit New Member

    ah, mail does not deliver wright!!

    AS you can see in the log file below he does
    if I send mail to [email protected] on the ns1.rayit.com it changes it to
    [email protected]!! why I do not know.!! :confused:


    ns1:/var/spool/mail# mail [email protected]
    Subject: test
    test
    Cc:
    ns1:/var/spool/mail# mailq
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    6BEBB372717* 2303 Thu Nov 3 22:21:55 MAILER-DAEMON
    [email protected]??????


    A ping to mail.rayit.com gives ns1 ip address.

    Do you know where to search...


    Nov 3 21:48:38 localhost postfix/smtp[9356]: 4F6CB372715: to=<[email protected]>, orig_to=<[email protected]>, relay=ns3.rayit.com[80.100.12.206], delay=1, status=bounced (host ns3.rayit.com[80.100.12.206] said: 550 <[email protected]>: Recipient address rejected: User unknown in local recipient table (in reply to RCPT TO command))
     
    Last edited: Nov 3, 2005
  9. rayit

    rayit New Member

    solved partly

    /etc/mailname !!!! had the wrong entry do not ask me how it got there!!

    changed that..

    now trying to solve remote mailing..

    Think DNS problem

    changed rayit.com from ns2 to ns1 and mail still goes to NS2 ...
     
    Last edited: Nov 3, 2005
  10. rayit

    rayit New Member

    YES i am getting mail on ns1 BUT

    The webmail and pop3 login still does not work ...
    The account web2_rmarx has mails in it.
    But can not login webmail with [email protected]
    or with pop3

    Nov 3 22:47:13 localhost ipop3d[12976]: pop3 service init from 127.0.0.1
    Nov 3 22:47:13 localhost ipop3d[12976]: Command stream end of file while reading line user=??? host=localhost.localdomain [127.0.0.1]


    Nov 3 22:52:04 localhost ipop3d[13163]: pop3 service init from 80.100.12.206
    Nov 3 22:52:04 localhost ipop3d[13163]: Command stream end of file while reading line user=??? host=dsl206-12-100.fastxdsl.nl [80.100.12.206]


    please help :confused: :(

    Raymond
    RayIT
     
    Last edited: Nov 3, 2005
  11. falko

    falko Super Moderator ISPConfig Developer

    You're using ipop3d which uses mbox format so make sure you've disabled Maildir under Management -> Server -> Settings -> Email.
     
  12. rayit

    rayit New Member

    tried it no result

    It was diabled, I tried enable and disable again.
    same results.

    What did I miss?
    Seems the pop3 mail boxes are not created or so?

    thanks

    raymond
     
  13. rayit

    rayit New Member

    Solved!!!!!

    apt-get install qpopper solved the problem!! :cool:

    I saw it installed on my other server..

    thanks


    Raymond
    RayIT
     

Share This Page