webmail subdomain nginx ispconfig3

Discussion in 'Installation/Configuration' started by commentator, May 2, 2014.

  1. commentator

    commentator Member


    I'm installing a new server with ispconfig3 an nginx on Debian.

    With Apache it was possible to create a vhost for webmail subdomain.

    So I searched a bit and found a bit code I changed to match my serversettings:
    webmail.vhost in nginx sites-enabled folderL
    server {
      server_name webmail.mydomain.ext;
      access_log /var/log/nginx/webmail-access.log;
      error_log /var/log/nginx/webmail-error.log;
      root /var/www/horde/;
      index index.php;
      location / {
        try_files $uri $uri/ /rampage.php?$args;
      location ~ \.php {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info;
        fastcgi_param PHP_VALUE "cgi.fix_pathinfo=1";
        fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_index index.php;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        include fastcgi_params;
    I pointed dns record to this and it worked.

    This worked untill I added mydomain.ext as site to ispconfig3.
    Now I get the "Welcome to your website!" message. So it looks like adding the site (with or without autosubdomain) changed how nginx serves the subdomain.
    How to fix it so I can use this webmail subdomain?
    Last edited: May 2, 2014

Share This Page