webmail problem

Discussion in 'General' started by mphayesuk, Apr 17, 2006.

  1. mphayesuk

    mphayesuk New Member

    Hi working on Suse 10 64bit with latest version of ispconfig.

    When I try and get to the webmail page after logging in I get the following error message

    Warning: Header may not contain more than a single header, new line detected. in /home/admispconfig/ispconfig/web/webmail/inc/inc.php on line 136

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/inc.php:136) in /home/admispconfig/ispconfig/web/webmail/msglist.php on line 65

    Any ideas.

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. mphayesuk

    mphayesuk New Member

    Got that bit working but when I try and send mail to a user using outlook I get the following error also I cant send mail out either.

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

    [email protected]
    Too many "Received" headers - suspected mail loop

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <[email protected]>
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by pih-relay04.plus.net with smtp (Exim) id 1FVVTE-0002Vn-Pl
    for [email protected]; Mon, 17 Apr 2006 16:16:56 +0100
    Received: (qmail 70868 invoked from network); 17 Apr 2006 15:16:56 -0000
    Received: from ptb-relay01.plus.net (212.159.14.212)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:56 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by ptb-relay01.plus.net with smtp (Exim) id 1FVVTE-0002tU-8L
    for [email protected]; Mon, 17 Apr 2006 16:16:56 +0100
    Received: (qmail 70860 invoked from network); 17 Apr 2006 15:16:55 -0000
    Received: from pih-relay05.plus.net (212.159.14.132)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:55 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by pih-relay05.plus.net with smtp (Exim) id 1FVVTD-0006jD-Cz
    for [email protected]; Mon, 17 Apr 2006 16:16:55 +0100
    Received: (qmail 70851 invoked from network); 17 Apr 2006 15:16:54 -0000
    Received: from ptb-relay01.plus.net (212.159.14.212)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:54 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by ptb-relay01.plus.net with smtp (Exim) id 1FVVTB-0002t2-DY
    for [email protected]; Mon, 17 Apr 2006 16:16:54 +0100
    Received: (qmail 70838 invoked from network); 17 Apr 2006 15:16:53 -0000
    Received: from pih-relay04.plus.net (212.159.14.131)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:53 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by pih-relay04.plus.net with smtp (Exim) id 1FVVTA-0002TM-Vi
    for [email protected]; Mon, 17 Apr 2006 16:16:53 +0100
    Received: (qmail 70835 invoked from network); 17 Apr 2006 15:16:52 -0000
    Received: from pih-relay05.plus.net (212.159.14.132)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:52 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by pih-relay05.plus.net with smtp (Exim) id 1FVVTA-0006hW-H2
    for [email protected]; Mon, 17 Apr 2006 16:16:52 +0100
    Received: (qmail 70832 invoked from network); 17 Apr 2006 15:16:52 -0000
    Received: from ptb-relay01.plus.net (212.159.14.212)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:52 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by ptb-relay01.plus.net with smtp (Exim) id 1FVVTA-0002r3-1v
    for [email protected]; Mon, 17 Apr 2006 16:16:52 +0100
    Received: (qmail 70827 invoked from network); 17 Apr 2006 15:16:51 -0000
    Received: from pih-relay04.plus.net (212.159.14.131)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:51 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by pih-relay04.plus.net with smtp (Exim) id 1FVVT9-0002Sq-Kv
    for [email protected]; Mon, 17 Apr 2006 16:16:51 +0100
    Received: (qmail 70824 invoked from network); 17 Apr 2006 15:16:51 -0000
    Received: from pih-relay06.plus.net (212.159.14.133)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:51 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by pih-relay06.plus.net with smtp (Exim) id 1FVVT9-00022c-5k
    for [email protected]; Mon, 17 Apr 2006 16:16:51 +0100
    Received: (qmail 70821 invoked from network); 17 Apr 2006 15:16:50 -0000
    Received: from ptb-relay01.plus.net (212.159.14.212)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:50 -0000
    Received: from [212.159.3.225] (helo=autoturn.force9.net)
    by ptb-relay01.plus.net with smtp (Exim) id 1FVVT8-0002qh-PW
    for [email protected]; Mon, 17 Apr 2006 16:16:50 +0100
    Received: (qmail 70817 invoked from network); 17 Apr 2006 15:16:50 -0000
    Received: from ptb-relay01.plus.net (212.159.14.212)
    by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:50 -0000
    Received: from [212.159.54.1] (helo=touch01)
    by ptb-relay01.plus.net with esmtp (Exim) id 1FVVT8-0002pb-9C
    for [email protected]; Mon, 17 Apr 2006 16:16:50 +0100
    Return-Receipt-To: "Martin Hayes" <[email protected]>
    From: "Martin Hayes" <[email protected]>
    To: <[email protected]>
    Subject: Testing
    Date: Mon, 17 Apr 2006 16:16:51 +0100
    Message-ID: <!&!AAAAAAAAAAAYAAAAAAAAACMRtkYEJ2JJsY4Oj57J7iHCgAAAEAAAAPbXVKYLHV1AhrHkbO0BGBYBAAAAAA==@touchone.co.uk>
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_NextPart_000_001B_01C6623A.55F7B480"
    X-Mailer: Microsoft Office Outlook 11
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    Thread-Index: AcZiLAqP3B7HmMhDQtavC0kRi1YreQ==
    Disposition-Notification-To: "Martin Hayes" <[email protected]>

    This is a multi-part message in MIME format.

    ------=_NextPart_000_001B_01C6623A.55F7B480
    Content-Type: text/plain;
    charset="us-ascii"
    Content-Transfer-Encoding: 7bit

    ect.....

    Any ideas
     
  4. mphayesuk

    mphayesuk New Member

    my main.conf

    sample_directory = /usr/share/doc/packages/postfix/samples

    # readme_directory: The location of the Postfix README files.
    #
    readme_directory = /usr/share/doc/packages/postfix/README_FILES
    inet_protocols = all
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    #virtual_maps = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = server1.$mydomain
    program_directory = /usr/lib/postfix
    inet_interfaces = all
    masquerade_domains =
    #mydestination = $myhostname, localhost.$mydomain
    defer_transports =
    disable_dns_lookups = no
    relayhost =
    mailbox_command =
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = yes
    smtpd_use_tls = yes
    smtp_use_tls = yes
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    mydomain = touchonehosting.co.uk
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_tls_auth_only = no
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
     
  5. mphayesuk

    mphayesuk New Member

    End Of My Mail Log File

    Apr 17 16:17:07 server1 postfix/smtpd[14461]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Apr 17 16:17:07 server1 postfix/smtpd[14461]: warning: inet_protocols: configuring for IPv4 support only
    Apr 17 16:17:07 server1 postfix/proxymap[14464]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Apr 17 16:17:07 server1 postfix/proxymap[14464]: warning: inet_protocols: configuring for IPv4 support only
    Apr 17 16:17:07 server1 postfix/smtpd[14461]: warning: connect to private/tlsmgr: No such file or directory
    Apr 17 16:17:08 server1 postfix/smtpd[14461]: warning: connect to private/tlsmgr: No such file or directory
    Apr 17 16:17:08 server1 postfix/smtpd[14461]: warning: problem talking to server private/tlsmgr: No such file or directory
    Apr 17 16:17:08 server1 postfix/smtpd[14461]: warning: no entropy for TLS key generation: disabling TLS support
    Apr 17 16:17:08 server1 postfix/smtpd[14461]: connect from localhost[127.0.0.1]
    Apr 17 16:17:08 server1 postfix/cleanup[14467]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Apr 17 16:17:08 server1 postfix/cleanup[14467]: warning: inet_protocols: configuring for IPv4 support only
    Apr 17 16:17:08 server1 postfix/smtpd[14461]: 2D10A340132: client=localhost[127.0.0.1]
    Apr 17 16:17:08 server1 postfix/cleanup[14467]: 2D10A340132: message-id=<[email protected]>
    Apr 17 16:17:08 server1 postfix/qmgr[14371]: 2D10A340132: from=<[email protected]>, size=801, nrcpt=1 (queue active)
    Apr 17 16:17:08 server1 postfix/smtp[14470]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Apr 17 16:17:08 server1 postfix/smtp[14470]: warning: inet_protocols: configuring for IPv4 support only
    Apr 17 16:17:08 server1 postfix/smtp[14470]: warning: connect to private/tlsmgr: No such file or directory
    Apr 17 16:17:08 server1 postfix/smtpd[14461]: disconnect from localhost[127.0.0.1]
    Apr 17 16:17:08 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 17 16:17:08 server1 pop3d: LOGIN, user=web1-user1, ip=[::ffff:127.0.0.1]
    Apr 17 16:17:08 server1 pop3d: LOGOUT, user=web1-user1, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Apr 17 16:17:09 server1 postfix/smtp[14470]: warning: connect to private/tlsmgr: No such file or directory
    Apr 17 16:17:09 server1 postfix/smtp[14470]: warning: problem talking to server private/tlsmgr: No such file or directory
    Apr 17 16:17:09 server1 postfix/smtp[14470]: warning: no entropy for TLS key generation: disabling TLS support
    Apr 17 16:17:29 server1 postfix/bounce[14482]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Apr 17 16:17:29 server1 postfix/bounce[14482]: warning: inet_protocols: configuring for IPv4 support only
    Apr 17 16:17:29 server1 postfix/smtp[14470]: 2D10A340132: to=<[email protected]>, relay=none, delay=21, status=deferred (Host or domain name not found. Name service error for name=touchone.co.uk type=MX: Host not found, try again)
    Apr 17 16:19:56 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 17 16:19:56 server1 pop3d: LOGIN, user=web1-user1, ip=[::ffff:127.0.0.1]
    Apr 17 16:19:56 server1 pop3d: LOGOUT, user=web1-user1, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0


    Thanks for any help given
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Looks like you built a mail loop...
     
  7. mphayesuk

    mphayesuk New Member

    :eek:

    :D

    So how do we fix this.....
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you change anything in your Postfix configuration recently?
     
  9. mphayesuk

    mphayesuk New Member

    no installed everything a month or so ago, and then updated to your latest release and then I am now testing it and found this problem. The only thing I have done is adjust the modprobe file to take out ipv6 so that I can get on the web.... thats all I have changed.

    Thanks
     
  10. mphayesuk

    mphayesuk New Member

    Could anything in my host files cause this problem:

    HOSTNAME - file contents (the case of this file is as it appears in the folder)
    server1.touchonehosting.co.uk

    hosts - file contents
    hosts This file describes a number of hostname-to-address # mappings for the TCP/IP subsystem. It is mostly # used at boot time, when no name servers are running. # On small systems, this file can be used instead of a # "named" name server. # Syntax: # # IP-Address Full-Qualified-Hostname Short-Hostname # 127.0.0.1 localhost # special IPv6 addresses ::1 localhost ipv6-localhost ipv6-loopback fe00::0 ipv6-localnet ff00::0 ipv6-mcastprefix ff02::1 ipv6-allnodes ff02::2 ipv6-allrouters ff02::3 ipv6-allhosts 212.159.54.3 server1.touchonehosting.co.uk server1 212.159.54.4 server1.touchonehosting.co.uk

    hosts.deny - file contents
    /etc/hosts.deny # See 'man tcpd' and 'man 5 hosts_access' as well as /etc/hosts.allow # for a detailed description. http-rman : ALL EXCEPT LOCAL Thanks
     
    Last edited: Apr 17, 2006
  11. falko

    falko Super Moderator ISPConfig Developer

    I guess this might cause the problem. Please change it back.

    Plese comment out the last line.
     
  12. mphayesuk

    mphayesuk New Member

    ok I have commented out the last line and also changed the modprobe back to its defaults, but still getting a mail loop. I have had to change modprobe again so that I can get internet access, on every install I have done I have had to change this file, so I dont think its the problem, all I am doing is turning off ipv6.

    So any other suggestions......

    Thanks
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Code:
    dig mx chesterfieldathletics.org.uk
    
    ; <<>> DiG 9.2.1 <<>> mx chesterfieldathletics.org.uk
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57967
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;chesterfieldathletics.org.uk.  IN      MX
    
    ;; ANSWER SECTION:
    chesterfieldathletics.org.uk. 14400 IN  MX      5 mail.chesterfieldathletics.org.uk.
    chesterfieldathletics.org.uk. 14400 IN  MX      10 autoturn.plus.net.uk.
    chesterfieldathletics.org.uk. 14400 IN  MX      20 mx.last.plus.net.
    
    ;; Query time: 159 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Tue Apr 18 10:38:09 2006
    ;; MSG SIZE  rcvd: 133
    Does mail.chesterfieldathletics.org.uk "know" that it is responsible for emails for [email protected]?
     
  14. mphayesuk

    mphayesuk New Member

    That is very interesting.... that domain was hosted by force9)plusnet) but I moved it to 123-reg.co.uk and defined the mx records myself to point to my new server (not on at the moment) so why does the dig output still show mx records for plusnet..... I am not sure what is going on or where to start to try and fix it.... what tool do you use to get the dig information.

    what do I need to start checking.

    Thanks
     
  15. mphayesuk

    mphayesuk New Member

    Thanks for pointing that out Falko it would appear that when I moved the domain names from one isp to another the nameservers were not changed so the mail was trying to go to plusnet and not to my server. I hope :confused:

    Thanks I will post again if this does not fix it.

    Thanks
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Well, the tool is called - dig... ;)
    Code:
    dig mx chesterfieldathletics.org.uk
     
  17. mphayesuk

    mphayesuk New Member

    Ok I am still having a problem with mail, I can send mail fine no problems, but getting mail in is still not working, and I think its something I have done with the dns settings.

    With the company I have registered my domains with I get free DNS management, so if anything what should I do with this, at the moment I have two a records one for www and one for mail, I then set the mx records to go to mail.domain.com. - this is all with the company I have registered with.

    1) So I am thinking that this is wrong and all I should do is change the nameserver settings for each of my domain names to point to my ispconfig server.

    2) so as per falkos single post I should leave one of my domain names dns settings with third party and set up nameserver a record entries and then the only settings I will need to change for all other domains is to set the nameserver to ns1.domain.com which has been set to my ispconfig server address.

    3) So I will leave the mail settings on the third party totally alone and not set them to anything.

    4) the MX records created on my ispconfig server are server1.domain.com and www is under the hostname.... is this right. after looking on the demo site there is no www under the hostname. So should I create a a record entry for mail or something.... this is where I am starting to get lost... any help would be good... THANKS
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    There is nothing wrong with the setup you described above.

    If you get external DNS for free, why do you want to use the ISPConfig DNS-Manager? If you can get DNS for free for you domain and you do not want to host a high number of domains and have some DNS knowledge, its always better to use the DNS from your registry.
     
  19. mphayesuk

    mphayesuk New Member

    So what your saying is I could use the DNS on my registra (third party) and just disable or delete the dns entries that ISPConfig has created and make sure that it doesnt create any for any new domain I put on.

    Thanks
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's right.
     

Share This Page