webmail problem after roundcubemail installation

Discussion in 'Installation/Configuration' started by Sinchan, May 18, 2010.

  1. Sinchan

    Sinchan New Member

    [solved] webmail problem after roundcubemail installation

    hi all,
    I had install roundcubemail to change squirrelmail as webmail in ISPConfig using this how to guide.
    Installation is succesfully without no error, and when i access http://mail.mydomain.com/webmail, roundcube welcome page is appeared. Its look like fine and no problem for me.
    I can login in roundcubemail using one of email user that had i added before. But less than 5 second, the webmail logout by it self. I'll try didnt do anything after login (didnt click mouse or keyboard) but that's errors still happen. I tried another email but same thing still happen. :mad:
    Iam using debian lenny with 1 primary and 1 slave ispconfig
    Anyone can help this problem please?
    Last edited: May 21, 2010
  2. Sinchan

    Sinchan New Member

    any help please?
  3. damir

    damir New Member

    Anything strange in log files?
  4. Hans

    Hans Moderator ISPConfig Developer

    What is the value of the variable
    within your RoundCube configuration file main.inc.php?
  5. Sinchan

    Sinchan New Member

    @damir :
    there's nothing special in log files, i had double check about this before. And in roundcubemail logs is empty (only .htaccess file)
    $ ls -lah /usr/share/squirrelmail/logs/
    total 12K
    drwxr-xr-x  2 root root 4.0K 2010-05-18 10:44 .
    drwxr-xr-x 10 root root 4.0K 2010-05-18 10:53 ..
    -rw-r--r--  1 root root   31 2010-05-18 10:44 .htaccess
    my email server is still able to work as usual, I was still able to send and receive email through my email client

    @Hans :
    my main.inc.php
    // Session lifetime in minutes
    // must be greater than 'keep_alive'/60
    $rcmail_config['session_lifetime'] = 30;
    i'd delete one of my domain, and then recreate new client, domain, and email user but still no luck :confused:
    any other suggestions?
  6. Hans

    Hans Moderator ISPConfig Developer

    That's ok.

    RoundCube has its own log files do you see any related errors there? You can also take a look at the log file one level higher then your roundcube /web folder. Anything there?
  7. Sinchan

    Sinchan New Member

    hi Hans, thanks for fast reply,
    AFAIK, most log is on /var/log/* and roundcubemail log is in /usr/share/installation-roundcubemail/logs/

    FYI, I do RoundCube installation in /usr/share/roundcubemail.
    And then i'd renamed that folder to /usr/share/squirrelmail, and add symbolic link to folder /var/www/webmail (same exactly like this guide. The different between my installation and this guide is only user,password, and database name in mysql)

    I'd check in /var/log there are no clue to roundcube related error logs, and in /usr/share/squirrelmail/logs is empty.
    Can you specify which log file/folder that you mean it?

    additional info :
    - OS : Debian 5 - 2.6.26-2-686 #1 SMP Tue Mar 9 17:35:51 UTC 2010 i686 GNU/Linux
    - ISPC : ISPConfig
    Last edited: May 20, 2010
  8. Sinchan

    Sinchan New Member


    after testing disabled/enabled php modules and trying to change several php.ini parameter, finally i found the problem : php5-suhosin :eek:
    It's still quite strange to me since im never change suhosin parameter (leave it as default) but when im disabled suhosin, the roundcubemail can work correctly.
    anyway, thanks Hans and damir :)
  9. Sinchan

    Sinchan New Member

    The problem solved. There is on suhosin.session.encrypt.
    But i dont want all website disabled suhosin.session.encrypt. I want disabled suhosin.session.encrypt only in roundcubemail.
    so i'd try add alias in apache config file like this :

    vi /etc/apache2/conf.d/webmail.conf
    Alias /webmail /usr/share/squirrelmail
    <Directory /usr/share/squirrelmail>
            Options Indexes FollowSymLinks
            DirectoryIndex index.php
            <IfModule mod_php5.c>
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_value include_path .
                    php_value suhosin.session.encrypt Off
    Its work !!
    Hope this thread help someone else that getting same error like me :)

Share This Page