Webmail Login Failed (3rd party works)

Discussion in 'Installation/Configuration' started by bluethunder82, Oct 1, 2006.

  1. bluethunder82

    bluethunder82 Member

    Hi All,
    This seems strange in my opinion. Most people of the forum cannot access via 3rd party pop3 clients. My problem is the reverse. I am having no troubles send/receiving mail from my mail cleint BUT I get an error from the webmail login.

    The error I get is:
    "You cannot login with the username and password entered.
    Please check your username and password and try again."

    The only error I get in both mail.log and mail.err is:
    "Oct 1 11:01:40 nexis courierpop3login: Connection, ip=[::ffff:]
    Oct 1 11:01:45 nexis courierpop3login: LOGIN FAILED, ip=[::ffff:]"

    I believe I am missing something in my main.cf file. Here is a stripped down version.

    Here is to hoping someone else has had this problem.

    smtpd_banner = $myhostname ESMTP $mail_name
    biff = no

    append_dot_mydomain = no

    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = no
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    myhostname = nexis.shewchuk.ca
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mynetworks =
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,
    reject_rbl_client sbl-xbl.spamhaus.org,
    reject_rbl_client cbl.abuseat.org,
    reject_rbl_client relays.ordb.org,
    reject_rbl_client bl.spamcop.net

    smtpd_tls_auth_only = no
    smtp_use_tls = no
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = localhost, /etc/postfix/local-host-names,
    -- END main.cf --

  2. Rocky

    Rocky New Member

    Are you trying to use your full email address as your login name?
  3. bluethunder82

    bluethunder82 Member

    Yes I am using the full email address. I was able to log into the system when I first setup the server (1 domain name). I have three now setup for testing and I have not been able to log in.

    I haven't modified anything for postfix since adding these extra domains. Thats why I am at such a lost.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that your websites each have a co domain which is the same then the website domain just without www in the host field.
  5. bluethunder82

    bluethunder82 Member

  6. falko

    falko Super Moderator ISPConfig Developer

    Please always use lowercase.
    Did you send an email to that email address before you tried to fetch emails from that account? If not, please do it now.
  7. bluethunder82

    bluethunder82 Member

    As my first email said I have been able to send and receive email with that account. The correct maildir structure is there. I have also sent a message to the accounts and checked once I saw the actual file present.

    I am using all lower case.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Then the spelling should be correct. And the website has the co-domain with the empty host field?


Share This Page