Webmail Login Error

Discussion in 'Installation/Configuration' started by slaeya, Mar 18, 2009.

  1. slaeya

    slaeya New Member

    I believe I have a working install of ISPconfig but am unable to login to webmail accounts.

    I'm not sure what I have done wrong this time.

    When I attempt to login to webmail I used multiple formats to rule it out -

    slaeya@ritzphoto.net
    pass

    web1_slaeya@ritzphoto.net
    pass

    web1_slaeya
    pass

    I get the error

    Code:
    You cannot login with the username and password entered.
    
    Please check your username and password and try again.
    
    I'm not sure where I am going wrong with this. It must be something simple if everything else seems to work. I have created more than one test email account to rule out user error in creating accounts.
     
    Last edited: Mar 18, 2009
  2. Ben

    Ben HowtoForge Supporter

    So you used the roundcube webmail package or which webmail app are you referring to?
    Are you referring to ISPCongi2 or are you already using ISPConfig3?

    Did you configure it your own (e.g. in RC to match usernames against the virtusertable, as the login against Imap may only be performed via the web___ username, thus RC need the virtusertable to translate this).

    What does e.g. /var/log/mail.log tell for the time of the failed login?

    To break it down to the webmailer, I guess the login with an "normal" emailclient like outlook, thunderbird etc. for those accounts works?
     
  3. slaeya

    slaeya New Member

    I'm using ISPConfig2, I didn't configure it on my own.

    /var/log/mail.log
    Code:
    Mar 18 20:49:56 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Mar 18 20:49:56 server1 authdaemond: authmysql: MYSQL_SERVER nor MYSQL_SOCKET set in/etc/courier/authmysqlrc.
    Mar 18 20:49:57 server1 pop3d: LOGIN FAILED, user=web2_slaeya, ip=[::ffff:127.0.0.1]
    Mar 18 20:49:57 server1 pop3d: authentication error: Input/output error
    
    I cannot connect with a mailclient IE. outlook or the webmail.
     
  4. Ben

    Ben HowtoForge Supporter

    Regarding to the use of ispconfig2 and pop3d throwing mysql errors for it looks like a misconfiguration, as ispconfig2 makes use of system user's and not virtual or in a DB stored ones.

    Did you use any howto from here to set your system up?
     
  5. slaeya

    slaeya New Member

    I used the perfect server ubuntu 8.10 howto.

    Unless this is the problem.

    I attempted to install ISPconfig3 as it was the latest version, only the install information does not match up with the Perfect Server Ubuntu 8.10 - it removed ftpserver and a couple of other packages and replaces them with others. I removed ISPconfig3 and replaced all my old packages.

    I then downloaded and installed ISPconfig2 which installed with no hassels at all - apart from the email problem.
     
  6. till

    till Super Moderator

    Did you format and completely reinstall the operation system of your server before you installed ispconfig 2 again? If not, ispconfig 2 will not work anymore after you installed ispconfig 3 and you will have to do a complete reinstall now.
     
  7. slaeya

    slaeya New Member

    I have now reinstalled ubuntu and am having other issues with ISPconfig3 I will post in a new thread. But thankyou for your help
     

Share This Page