Webmail Client over SSL

Discussion in 'Server Operation' started by alleks, Feb 15, 2011.

  1. alleks

    alleks Member

    Hello folks, here I come to you with another problem :)

    This time I try to run my webmail client (atmail) over ssl. I tried to do that by just adjusting the parameters in my squirrelmail.conf file in conf.d apache2's folder.

    Code:
    <IfModule mod_rewrite.c>
      <IfModule mod_ssl.c>
        <Location /webmail>
          RewriteEngine on
          RewriteCond %{HTTPS} !^on$ [NC]
          RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]
        </Location>
      </IfModule>
    </IfModule>
    
    It goes well, it redirects from http://domain.com/webmail to https://domain.com/webmail but when it gets there I get this error in my chrome browser:

    Code:
    SSL connection error
    Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.
    Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.
    
    and this in my apache2/error.log

    Code:
    client denied by server configuration: /htdocs
    
    Any idea?
     
  2. pititis

    pititis Member

    First make sure that ssl 2.0 and 3.0 are set in chrome!
     
  3. alleks

    alleks Member

    It's not happening only in chrome, in all my browsers.

    I had checked the ssl versions before posting here :)
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  5. alleks

    alleks Member

    No, I run https for ISPConfig and it runs great... but I can't get it to work for webmail (atmail).

    Any other ideas?
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is your webmail installed in the /webmail folder of your web site, or is /webmail just an alias or symlink?
     
  7. 8omas

    8omas New Member HowtoForge Supporter

    Do you run ispconfig on 443 or on another port?
    If you followed the manual (ispconfig on 8080) and you enabled https then the rewrite rule must be:
    Code:
    RewriteRule . https://%{HTTP_HOST}:8080%{REQUEST_URI}  [L]
     

Share This Page