Webmail and main.cf

Discussion in 'Installation/Configuration' started by jokuleo, Feb 8, 2007.

  1. jokuleo

    jokuleo New Member

    Hello, it seems that if I dont't add

    check_relay_domains

    to "smtpd_recipient_restrictions ="

    Webmail (Uebimiau and Squirrelmail) is not able to send Mails to the "outside world".

    I followed different posts and ended up with this (I left out the spam related entries):

    Code:
    smtpd_recipient_restrictions =
            permit_mynetworks,
            permit_sasl_authenticated,
            reject_invalid_hostname,
            reject_non_fqdn_hostname,
            reject_non_fqdn_sender,
            reject_non_fqdn_recipient,
            reject_unknown_sender_domain,
            reject_unknown_recipient_domain,
            reject_unauth_destination,
            permit
    But it's not working... Squirrelmail tells "relay access denied"...

    This one is doing the job...

    Code:
    smtpd_recipient_restrictions =
            permit_mynetworks,
            [B]check_relay_domains[/B],
            permit_sasl_authenticated,
            reject_invalid_hostname,
            reject_non_fqdn_hostname,
            reject_non_fqdn_sender,
            reject_non_fqdn_recipient,
            reject_unknown_sender_domain,
            reject_unknown_recipient_domain,
            reject_unauth_destination,
            permit
    The rest of the main.cf is just like when using the perfect setup for sarge.

    It would be no problem at all but I read that "check_relay_domains" should not be used anymore?!

    So could you give me a hint on a "modern" main.cf?

    Thanks

    jokuleo
     
  2. jokuleo

    jokuleo New Member

  3. jokuleo

    jokuleo New Member

    No, it's NOT doing the job... Now the "normal" Mail-Clients are telling that they aren't allowed... Webmail is working... :eek:
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You must enable "Server requires authentication." in your email clients.
     

Share This Page