/webmail 404 not found on this server

Discussion in 'HOWTO-Related Questions' started by White, Sep 11, 2016.

  1. White

    White Member

    hi all havent been on here for a while and ive forgot more than i remember so im in need of help. I have followed,

    The Perfect Server - Ubuntu 16.04 (Xenial Xerus) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1

    i have been having problems as originally the email button that links to the email didnt work from the ispconfig dashboard and neither did /webmail returning a 404 error as it really didnt exist.

    I finally spooted in the settings for email in ispconfig 3.1 has the alias of /webmail but the tutorial sets the alias up on page 3 as /roundcube which i have found out this morning but before i did i had completely mucked up the email side of it trying to get squirrelmail to work as i didnt know roundcube was an email client. S i did apt-get remove for squirrelmail and roundcube

    I have gone through the set up again and the button works and it opens roundcube Hoorah but the this error pops up

    Unable to connect to the database!
    Please contact your server-administrator.

    i have to roundcube databases now in phpmyadmin roundcube and roundcubedb so i need helpchecking the settings and curing the mysql error for the roundcube db i have mucked up. please i am a dummy so please explain each step.
  2. CreeWarrior

    CreeWarrior Member

    I think you can try to update then reconfigure services to see if that helps

    Run as root
    Select update method (stable,svn) [stable]:
    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:
    Reconfigure Permissions in master database? (yes,no) [yes]:
    Reconfigure Services? (yes,no) [yes]:
    ISPConfig Port [8080]:
    Create new ISPConfig SSL certificate (yes,no) [no]:
    Reconfigure Crontab? (yes,no) [yes]:

    Hope that helps
  3. White

    White Member

    thanks for the reply i got this with nothing after the first enter
    [email protected]:/home/administrator# ispconfig_update.sh
    Note: Update all slave server, before you update master server.

    Select update method (stable,git-stable,git-master) [stable]:

    There are no updates available for ISPConfig 3.1dev
    [email protected]:/home/administrator#

    Now i know that when i first started playing i read a how to that had
    mysql -u root -p and there was a line im taking from memory using password=["roundcube"] and then another time when it broke the next howto had this line
    GRANT ALL PRIVILEGES ON `roundcube` . * TO 'roundcube'@'localhost' IDENTIFIED BY 'mySecretPassword'; which i gave my own password to

    what i need to do is make sure that ispconfig is reading off the correct database and that it has the correct user and password.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The roundcube url is /roundcube and not /webmail. This url is configurable in ispconfig, login to ispconfig, go to System > Interface config and set the full url to your webmail application there. Do not alter any database rights or remove any packages, your problem is not related to the roundcube database and ispconfig never connects to the roundcube db. If you need to reinstall roundcube, then ensure that you remove the roundcube db and the roundcube mysql user with phpmyadmin first before you try to install it again with apt.
  5. White

    White Member

    ok i have tried to remove all traces of roundcube from step 16
    apt-get remove --auto-remove roundcube roundcube-core roundcube-mysql roundcube-plugins roundcube-plugins-extra javascript-common libjs-jquery-mousewheel php-net-sieve tinymce

    i can then start the reinstall however i get the following error

    ┌──────────────────────┤ Configuring roundcube-core ├──────────────────────┐
    │ │
    │ An error occurred while installing the database:

    │ ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using
    │ password: NO) . Your options are:
    │ * abort - Causes the operation to fail; you will need to downgrade, etc etc etc

    if i sign into mysql using
    mysql -u root -p
    i have to put in my password

    what do i need to do to sort this out ?

Share This Page