Webinterface not shown any more after update

Discussion in 'Installation/Configuration' started by tomt2002, Apr 29, 2010.

  1. tomt2002

    tomt2002 New Member

    Dear All,

    i did the update of ISPConfig3 to the newest version but after that the webinterface is not shown any more. the webpages are still valid but we can´t get access to the webinterace.

    for the update we use all the defaults exept the mysql password that we retype.

    i´m not sure if the ispconfig is still running, could i check this ?

    any idea to fix this ?

    many Thanks !
     
    Last edited: Apr 29, 2010
  2. charlesrg

    charlesrg New Member

    Did you check /var/log/apache2/error.log ?
    Check your /var/log/syslog /var/log/messages

    Check if your ispconfig.vhost is correct and do a apache2ctl -t
     
  3. tomt2002

    tomt2002 New Member

    first off all i use CENTOS (i forgot to mention).

    the error log shows the following entries:
    [Thu Apr 29 15:15:03 2010] [notice] caught SIGTERM, shutting down
    [Thu Apr 29 15:16:43 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Apr 29 15:16:43 2010] [notice] Digest: generating secret for digest authentication ...
    [Thu Apr 29 15:16:43 2010] [notice] Digest: done
    Use of uninitialized value in alarm at /usr/local/ispconfig/server/scripts/vlogger line 531.
    [Thu Apr 29 15:16:45 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Apr 29 15:16:45 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
    [Thu Apr 29 15:31:55 2010] [notice] caught SIGTERM, shutting down
    [Thu Apr 29 15:33:25 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Apr 29 15:33:25 2010] [notice] Digest: generating secret for digest authentication ...
    [Thu Apr 29 15:33:25 2010] [notice] Digest: done
    [Thu Apr 29 15:33:27 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Apr 29 15:33:27 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
    [Thu Apr 29 17:13:33 2010] [error] [client 89.245.137.140] (13)Permission denied: access to /index.php denied
    [Thu Apr 29 17:13:33 2010] [error] [client 89.245.137.140] (13)Permission denied: access to /index.html denied
    [Thu Apr 29 17:13:33 2010] [error] [client 89.245.137.140] (13)Permission denied: access to /index.html.var denied
    [Thu Apr 29 17:13:35 2010] [error] [client 89.245.137.140] (13)Permission denied: access to /index.php denied
    [Thu Apr 29 17:13:35 2010] [error] [client 89.245.137.140] (13)Permission denied: access to /index.html denied
    [Thu Apr 29 17:13:35 2010] [error] [client 89.245.137.140] (13)Permission denied: access to /index.html.var denied
    [Thu Apr 29 17:37:24 2010] [notice] caught SIGTERM, shutting down
    [Thu Apr 29 17:37:34 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Apr 29 17:37:35 2010] [notice] Digest: generating secret for digest authentication ...
    [Thu Apr 29 17:37:35 2010] [notice] Digest: done
    [Thu Apr 29 17:37:35 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Apr 29 17:37:35 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
    [Thu Apr 29 17:42:06 2010] [notice] caught SIGTERM, shutting down
    [Thu Apr 29 17:42:07 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Apr 29 17:42:07 2010] [notice] Digest: generating secret for digest authentication ...
    [Thu Apr 29 17:42:07 2010] [notice] Digest: done
    [Thu Apr 29 17:42:07 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Apr 29 17:42:08 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
    [Thu Apr 29 17:59:20 2010] [notice] caught SIGTERM, shutting down
    [Thu Apr 29 18:00:50 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Apr 29 18:00:51 2010] [notice] Digest: generating secret for digest authentication ...
    [Thu Apr 29 18:00:51 2010] [notice] Digest: done
    Use of uninitialized value in alarm at /usr/local/ispconfig/server/scripts/vlogger line 531, <CONF> line 1.
    [Thu Apr 29 18:00:54 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Apr 29 18:00:54 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
    ~

    the command apache2ctl -t is not available, but apachectl -t was existing and i try.
    shows "Syntax OK"

    the ispconfig.vhost looks like:
    Listen 8080
    NameVirtualHost *:8080

    <VirtualHost _default_:8080>
    ServerAdmin [email protected]

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    php_value magic_quotes_gpc 0
    </Directory>
    </IfModule>

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    </VirtualHost>

    <Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>


    thanks for your help !
     
    Last edited: Apr 30, 2010
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The config seems to be ok so far.

    1) Is this a server from ovh?
    2) Post the output of:

    netstat -tap
     
  5. tomt2002

    tomt2002 New Member

    Hello Till,

    what do you mean with ovh ?

    netstat -tap shows:
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:10024 *:* LISTEN 1490/amavisd (maste
    tcp 0 0 localhost.localdomain:10025 *:* LISTEN 1573/master
    tcp 0 0 *:mysql *:* LISTEN 1426/mysqld
    tcp 0 0 localhost.local:dyna-access *:* LISTEN 1346/clamd
    tcp 0 0 *:sunrpc *:* LISTEN 1009/portmap
    tcp 0 0 *:ftp *:* LISTEN 1627/pure-ftpd (SER
    tcp 0 0 web3.pro-domain.eu:domain *:* LISTEN 1453/mydns
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 1453/mydns
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 1335/cupsd
    tcp 0 0 *:smtp *:* LISTEN 1573/master
    tcp 0 0 *:798 *:* LISTEN 1040/rpc.statd
    tcp 0 0 web3.pro-domain.eu:smtp 58.186.216.212:60721 TIME_WAIT -
    tcp 0 0 *:imaps *:* LISTEN 1508/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 1520/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 1514/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 1501/couriertcpd
    tcp 0 0 *:webcache *:* LISTEN 1617/httpd
    tcp 0 0 *:http *:* LISTEN 1617/httpd
    tcp 0 0 *:tproxy *:* LISTEN 1617/httpd
    tcp 0 0 *:ftp *:* LISTEN 1627/pure-ftpd (SER
    tcp 0 0 localhost6.localdoma:domain *:* LISTEN 1453/mydns
    tcp 0 0 *:ssh *:* LISTEN 1327/sshd
    tcp 0 0 *:https *:* LISTEN 1617/httpd
    tcp 0 0 web3.pro-domain.eu:http crawl-66-249-66-7.goo:46962 TIME_WAIT -
    tcp 0 0 web3.pro-domain.eu:http indesit.netcraft.com:9680 TIME_WAIT -
    tcp 0 148 web3.pro-domain.eu:ssh dslb-088-076-198-233.:49589 VERBUNDEN 13980/0
    tcp 0 0 web3.pro-domain.eu:http indesit.netcraft.com:9723 TIME_WAIT -
    tcp 0 0 web3.pro-domain.eu:http indesit.netcraft.com:9710 TIME_WAIT -
     
    Last edited: May 1, 2010
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then I assume no :) OVH is a provider that offers servers with ispconfig installed.

    Did you access ispconfig with http or https? If you reconfigured it to use https, then you might have to redo this modification after an update.
     
  7. yoplait

    yoplait Member

    Is there a problem between OVH and ispconfig ?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No, not at all. OVH configures ispconfig with ssh on the interface. Thats absolutley fine, but ispconfig removes this on update so it looks like the intreface is not accessible anymore if you try to access it in https after the update. So to be able to find the reason for this problem, it is good to know if its and ovh server or not.
     
  9. tomt2002

    tomt2002 New Member

    Hello Till,

    no we didn´t modify it to https, so we use http.

    in the meantime we do some addition testing an it seems that sending and receiving emails is not possible any more at all hosted domains on that server.

    the domains itselfs are still working and we could login to webmail but nothing happens.

    i check the maillog and found the following entries:
    May 2 04:06:03 web3 postfix/smtpd[29414]: warning: SASL: Connect to private/auth failed: No such file or directory
    May 2 04:06:03 web3 postfix/smtpd[29414]: fatal: no SASL authentication mechanisms

    May 2 04:03:40 web3 sendmail[28972]: o4222l7p028972: to=root, ctladdr=root (0/0), delay=00:00:53, xdelay=00:00:19, mailer=relay, pri=30434, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection reset by [127.0.0.1]

    May 2 04:07:05 web3 postfix/master[1573]: warning: process /usr/libexec/postfix/smtpd pid 29486 exit status 1
    May 2 04:05:03 web3 postfix/master[1573]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

    any idea ?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

  11. tomt2002

    tomt2002 New Member

    Hello Till,

    thanks - now E-Mail seems to be working again.

    the webinterface was a problem with an entry in a lokal firewall, now it´s working, too.
     

Share This Page