webhosting but not mailhosting

Discussion in 'General' started by pbrille, Jan 18, 2010.

  1. pbrille

    pbrille New Member


    I'm using an ISPconfig 2 where a domain ist hosted for http. Let's name it Server A for customer A and domain A.
    The mx-record is pointing to another server (Server B). This is not a problem since someone external sends to this domain.
    But when another client that is hosted on server A tries to send an Email to customer A, the Server A feels responsible, but he's not, because Server B is.

    How can I tell Server A that every Email for domain A shall be forwarded to Server B?

    THX a lot

    Sorry, I chose the wrong Forum. Could someone please move my Thread?
    Last edited: Jan 18, 2010
  2. pbrille

    pbrille New Member

    Ok, I ask differently.
    Will ISPConfig 2 overwrite the file /etc/postfix/local-host-names if I change it manually???
    If so, what would be a solution?
  3. falko

    falko Super Moderator ISPConfig Developer

    Go to the Options tab of that web site and select "External Mailserver". Also do this for the Co-Domains - go to the Co-Domains tab, select the Co-Domain, and select "External Mailserver" on the Options tab of that Co-Domain.

    Yes, unless you make your changes at the end of the file.
  4. pbrille

    pbrille New Member

    I changed the settings as described within the web-interface. Additionally I had to remove the line from "/etc/postfix/local-host-names" which told postfix to deliver locally for that very domain. At first it worked fine.

    Unfortunately the line with this particula domain was reinserted by ISPconfig into that file. So now it's not working again. What can I do to prevent ISPconfig from inserting that line. I thought changing to the "external mailserver" option would be enough. Maybe it's because of my version which is 2.2.16.

    Please Help!
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you also do this for the Co-Domains?
  6. pbrille

    pbrille New Member

    No, I did not. I hope this'll be it...

Share This Page