webdav + new ispc3 support + debian?

Discussion in 'Installation/Configuration' started by crypted, Oct 19, 2010.

  1. crypted

    crypted New Member

    I can't find a guide to install Webdav on Debian Lenny so that it will work with the new built-in webdav support with ISPC3.

    Anyone know of a good instruction set for that?

    WebDav is not installed as far as I know. I used the Perfect Setup Guide for Lenny (x64 though that isn't relevant really) back in early April 2010. I don't recall Webdav and my locate doesn't show anything but Webdav ISPCONFIG files.

    My Google search hasn't been stellar. But, that's been my day in general!!!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. crypted

    crypted New Member

    Code:
    my:/home/dingle# apt-get install libapache2-mod-ruby
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
      libapache-ruby1.8
    Suggested packages:
      liberuby
    The following NEW packages will be installed:
      libapache-ruby1.8 libapache2-mod-ruby
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 86.1kB of archives.
    After this operation, 328kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 [url]http://ftp.us.debian.org[/url] lenny/main libapache-ruby1.8 1.2.6-2 [20.5kB]
    Get:2 [url]http://ftp.us.debian.org[/url] lenny/main libapache2-mod-ruby 1.2.6-2 [65.6kB]
    Fetched 86.1kB in 0s (119kB/s)            
    Selecting previously deselected package libapache-ruby1.8.
    (Reading database ... 108004 files and directories currently installed.)
    Unpacking libapache-ruby1.8 (from .../libapache-ruby1.8_1.2.6-2_all.deb) ...
    Selecting previously deselected package libapache2-mod-ruby.
    Unpacking libapache2-mod-ruby (from .../libapache2-mod-ruby_1.2.6-2_amd64.deb) ...
    Setting up libapache-ruby1.8 (1.2.6-2) ...
    Setting up libapache2-mod-ruby (1.2.6-2) ...
    Enabling module ruby.
    Run '/etc/init.d/apache2 restart' to activate new configuration!
    my:/home/dingle# /etc/init.d/apache2 restart
    Restarting web server: apache2[Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.216:443 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.217:443 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.210:443 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.211:443 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.214:443 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.215:80 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.215:443 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.212:443 has no VirtualHosts
    [Tue Oct 19 10:18:54 2010] [warn] NameVirtualHost 66.118.142.213:443 has no VirtualHosts
     ... waiting [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.216:443 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.217:443 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.210:443 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.211:443 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.214:443 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.215:80 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.215:443 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.212:443 has no VirtualHosts
    [Tue Oct 19 10:18:55 2010] [warn] NameVirtualHost 66.118.142.213:443 has no VirtualHosts
    Unable to store vlogger data in database
    .
    my:/home/dingle# 
    That broke something. Now I get "Unable to store vlogger data in database"
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The vlogger issue is most likely not related to the new packages that you have installed.

    Is this a multiserver or single server install and if its a multiserver, is this the master or slave?
     
  5. crypted

    crypted New Member

    Single server.

    I restarted Apache two days ago. I didn't get that error.

    This is the first package change since that last restart.

    Weird.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that the mysql login details in the file /etc/vlogger-dbi.conf are identical to the ones that you find in /usr/local/ispconfig/server/lib/config.inc.php.

    Regarding the namevirtualhost warnings, go to system > server ip, edit one of the ip addresses and uncheck the namevirtualhost checkbox. Click on save, then edit it again and enable it and click on save again.
     
  7. crypted

    crypted New Member

    The two files match for the db, user, and passwd. I've not had that error literally until I did those steps to install Webdav. Nothing else has been edited. However, the error has disappeared on its own, cool and weird.

    Code:
    my:/home/dingle# /etc/init.d/apache2 restart
    Restarting web server: apache2[Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.216:443 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.217:443 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.210:443 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.211:443 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.214:443 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.215:80 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.215:443 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.212:443 has no VirtualHosts
    [Tue Oct 19 11:26:34 2010] [warn] NameVirtualHost 66.118.142.213:443 has no VirtualHosts
     ... waiting .[Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.216:443 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.217:443 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.210:443 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.211:443 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.214:443 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.215:80 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.215:443 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.212:443 has no VirtualHosts
    [Tue Oct 19 11:26:37 2010] [warn] NameVirtualHost 66.118.142.213:443 has no VirtualHosts
    .
    my:/home/dingle# 
    
    I've had the namevhost errors since I installed ISPC3 and have just ignored them. But, I did the steps you've mentioned by editing an IP by deleting a trailing number and unchecking, saving, and then redoing the changes. Still get the same error.

    EDIT: Might be worth noting that I checked another IP to use NameVirtualHost that was not using it before. It came up with the same error as the rest of the IPs. So, I unchecked it. It is no longer in the list of problems on restart of Apache, but the rest still have issues.
     
    Last edited: Oct 19, 2010

Share This Page