Webdav access fails

Discussion in 'Installation/Configuration' started by jarome, Nov 22, 2011.

  1. jarome

    jarome New Member

    I set up my own site under ISPConfig3 on OpenSUSE 12.1, and made 3 Webdav users. The directories seem correct: /srv/www/clients/client1/web1/webdav/myfiles.
    I also specified this as being https.

    I also made a main site using the address of my server: myname.dyndns.org

    But when I try to go to (in Konqueror)
    webdavs://mysite.dyndns.org/webdav/myfiles (which exists and has a file in it), I get "File or folder does not exist". And it never asked me for my login.

    What am I doping wrong?

    Thanks,
    Jim
     
    Last edited: Nov 22, 2011
  2. falko

    falko Super Moderator

    Are there any errors in Apache's error log?
     
  3. jarome

    jarome New Member

    errors

    I get lots of
    piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
    and also

    piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
    [Tue Nov 22 12:37:55 2011] [error] [client 192.168.1.11] PHP Notice: Undefined index: on_after_insert in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 139, referer: https://192.168.1.70:8080/index.php
    [Tue Nov 22 12:37:55 2011] [error] [client 192.168.1.11] PHP Notice: Undefined index: sites:eek:n_after_insert in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 139, referer: https://192.168.1.70:8080/index.php
    [Tue Nov 22 12:37:55 2011] [error] [client 192.168.1.11] PHP Notice: Undefined index: sites:webdav_user:eek:n_after_insert in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 139, referer: https://192.168.1.70:8080/index.php
    [Tue Nov 22 12:37:55 2011] [error] [client 192.168.1.11] PHP Notice: Undefined index: return_to_url in /usr/local/ispconfig/interface/lib/classes/tform_actions.inc.php on line 218, referer: https://192.168.1.70:8080/index.php

    I attach the full log
     

    Attached Files:

  4. till

    till Super Moderator

    Which ISPConfig version do you have installed and which guide did you use to prepare your server for ISPConfig?
     
  5. jarome

    jarome New Member

    Answers

    ISPConfig3. I downloaded and installed them yesterday and pretty much followed the Suse 12.1 as a perfect server guide. I had installed 12.1 already, so a few things were different, but not many.

    I do have the ISPConfig guide. But my goal is to just have an easy way to set up a site for myself.
     
  6. till

    till Super Moderator

    ISPConfig 3 is the name of the software, not the version. You can find the version number under: Help > Version
     
  7. jarome

    jarome New Member

    answer

    Downloaded two days ago, sdo the latest--3.0.4
     

Share This Page