Discussion in 'General' started by fobicodam, Jul 2, 2006.

  1. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    I was reading all previous post but i cant find an answer to my problem. Webalizer doesnt run "automatically".

    As ive read, the httpd log files mut be called somthing like "ispconfig_access_log_2006_05_2" but in my server they are called "access_log", no "ispconfig", no dates, no nothing.. they are numbered too.

    /root/ispconfig/scripts/shell/logs.php runs with no error, so i edited and uncomment every "echo" step. I get this:

    opening: /var/log/httpd/ispconfig_access_log_2006_07_01

    And then, the prompt. So, i imagine he cant read the log files, i edited the file to read "/var/log/httpd/access_log" as it is on my server.

    I tried this:

    //$access_log = $server["server_path_httpd_log"] . "_" . date("Y_m_d",time() - 43200);
    $access_log = $server["server_path_httpd_log"];

    but i get a lot of errors.


    Warning: fopen(/home/www/ - - [25/Jun/2006:07:01:13 -0300] "GET /Portal%20nuevo/imagenesplanillas/menuplantilla.jpg HTTP/1.1" 200 17862 "http://www.alimentacion-sana.com.ar/informaciones/novedades/conservacion%203.htm" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; SIMBAR Enabled)"
    /log/2006/07/web.log): failed to open stream: No such file or directory in /root/ispconfig/scripts/shell/logs.php on line 91

    Warning: mkdir(): File exists in /root/ispconfig/scripts/lib/classes/ispconfig_file.lib.php on line 155


    At least now is reading the log file, but, is it trying to open the log items as filenames? i dont know, but it doesn work !!

    Can you help me?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /var/log/httpd/

    This file has the wrong format. Dont change any ISPConfig script if you wont add any new functions, the scripts delivered with ISPConfig are working, otherwise we would have released a bugfix!
    Last edited: Jul 3, 2006
  3. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    I noted that, so i went to the httpd.conf file to see what else could be wrong, i found quoted the line where ispconfig set the log format, i uncomment it and now it seems to be working. I have the cron problem right now, i hope i could fix it tonight..

  4. falko

    falko Super Moderator ISPConfig Developer

Share This Page