Webalizer statistics only creates a daily stats

Discussion in 'Installation/Configuration' started by filipealvarez, May 8, 2009.

  1. filipealvarez

    filipealvarez New Member

    Hi there, I found one problem in the Ispconfig3/Webalizer on Ubuntu 8.04,
    the webalizer only creates a daily stat (not acumulate the days).

    Example: www.temautos.com.br/stats

    How to fix it?
    Is something in /etc/webalizer/webalizer.conf or with the logs?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    you have to enable the partial log feature in webalizer.conf
     
  3. filipealvarez

    filipealvarez New Member

    Thanks Till, add 'Incremental Yes' in webalizer.conf solves my problem.
     
  4. martin1977

    martin1977 New Member

    Is there a way to "re-read" those stats that were forgot before enabling this option?

    Best regards,
    Martin
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No, not as far as I know as the log that is used to create the statistics is deleted after some days.
     
  6. martin1977

    martin1977 New Member

    OK, I found a way to feed webalizer with the "forgotten" statistics.

    The following will go through the access log files for each domain and gather the information in the todays log file. The old logs are deleted (as the information is now stored in the actual log) to prevent running the command twice and dubblicating data by mistake.

    Code:
    find /var/log/ispconfig/httpd -name "*.gz" |while read g; do gzip -fd $g; done && find /var/log/ispconfig/httpd/ -maxdepth 1 -mindepth 1 -type d | while read i ; do rm $i/access.log && cat $i/*-access.log >> $i/access.log && rm $i/*-access.log && mv $i/access.log  $i/`date +%Y%m%d`-access.log && ln -s $i/`date +%Y%m%d`-access.log $i/access.log; done
    Next time webalizer is running statistics it will consider all available information from the past days. Thereafter everything will run as usual.
    ( Do not forget to change the option "Incremental yes" in /etc/webalizer/webalizer.conf).

    Best regards,
    Martin
     

Share This Page