webalizer problem

Discussion in 'Installation/Configuration' started by freeborn, Aug 9, 2006.

  1. freeborn

    freeborn New Member

    My distro is Fedora Core 4.
    I follow every single step of the perfect setup.
    My problem is webalizer doesn't work as I expect.
    I can't get the stats at http://myweb/stats/
    but I find the stat in /var/log/httpd and it's the stats for all.
    I'd like to get stats for every single vertual host and can access like

    http://vertualhostname/stats/

    Could any one please show me the details of configuration?
    Please be noted that I'm not the Linux expert.

    Thanks in advance,
    ________
    NO2 VAPORIZER REVIEW
    ________
    WEB SHOWS
     
    Last edited: Aug 16, 2011
  2. fobicodam

    fobicodam ISPConfig Developer

    This problem was fixed several times, use the search function. Its the cron job, it doesnt work as expected..
     
  3. falko

    falko Super Moderator

    The stats folder is created at 4.00h in the morning. Did you wait long enough?
     
  4. freeborn

    freeborn New Member

    I wait more than 5 days now.
    I've searched this forum regarding webalizer and try to run webalizer.php.
    After that I found directory called stats in VHost but
    the problem still exist even more webalizer doesn't work now.
    I don't see any changes in /var/www/usage after I ran webalizer.php.

    Please give me suggestion.
    :(
    ________
    vapir oxygen vaporizer
    ________
    LIVE SEX
     
    Last edited: Aug 16, 2011
  5. Hans

    Hans Moderator

    A suggestion

    Try this:

    /etc/init.d/cron stop
    pkill cron (Make sure no cron processes are left.)
    Edit your crontab (crontab -e) and save it again.
    Then restart cron: /etc/init.d/cron start

    Wait max. 24 hours...


    It worked for some of us.
    Maybe you're lucky too...:)
     
  6. freeborn

    freeborn New Member

    Thank a million Hans,

    Could you please give me details of crontab(command sets) I should edit?
    I'm just a kid in Linux world.
    ________
    Expert Insurance
    ________
    WEB SHOWS
     
    Last edited: Aug 16, 2011
  7. Hans

    Hans Moderator

    If you do an crontab -e (as root) It should contain this line:

    0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null

    This means that at 4:00 (every night) webalizer creates stats for you.

    Be sure that Web stats ar enabled in ISPConfig for the website.

    The webstatistics are stored in the stats directory of your web.
     
  8. freeborn

    freeborn New Member

    Last edited: Aug 16, 2011
  9. freeborn

    freeborn New Member

    I'm still getting no luck.
    there was nothing happen, I've checked /var/log/cron and it's OK.
    There was a job at 4 am in the morning but I still see no stats.
    I found that the stats at /var/www/usage still no change since 200608.

    Help please. :confused:
    ________
    NEW JERSEY MARIJUANA DISPENSARY
    ________
    CuteJenny
     
    Last edited: Aug 16, 2011
  10. Hans

    Hans Moderator

    I found out that for Fedora it must be: /etc/init.d/crond stop

    Please have also a look here:

    http://www.howtoforge.com/forums/showthread.php?t=562&highlight=webalizer
     
  11. freeborn

    freeborn New Member

    Thanks Hans

    I already fixed that and cron is working fine now.
    The problem is webalizer doesn't work.

    Any procedures I should do?

    Thanks again.
    ________
    latin girl Cams
    ________
    Live Sex Webshows
     
    Last edited: Aug 16, 2011
  12. Ovidiu

    Ovidiu Active Member

    I suggest you read this post here http://www.howtoforge.com/forums/showthread.php?t=562 and try everything mentioned.

    1. stop cron, crontab -e, save, start cron
    2.retype your crontab manually after emptying it.
    3.go to ispconfig, login as admin, go to the site tha does not produce stat, go to options and below, uncheck
    save the site, wait some minutes, check it again and save the site again.

    #3 seems to have helped me, since this morning my stats appeared again. I feel a bit like doing voodoo magic here, try this and pray, try that and pray :D
     
  13. Hans

    Hans Moderator

    Last edited: Aug 12, 2006
  14. freeborn

    freeborn New Member

    Finally I can solve problem after reading few posts and try again.

    The problem is there is no cron job for root by default in Fedora distro.
    The stats doesn't compile if I only add a command calling webalizer.php.
    But when I add another command calling logs.php before webalizer.php , the stats starts compiling.
    Here are the procedures I did

    /etc/init.d/crond stop
    pkill crond
    crontab -e

    then add the following
    30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
    0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
    0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
    15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
    40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
    05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null

    then start crond again
    /etc/init.d/crond start

    then login ispconfig -> goto site you want -> choose option tab and unchecked Webalizer Statistic -> Save
    after few minutes rechecked Webalizer Statistic and Save again

    and just wait one night.

    Thanks agian Hans, Tenaka, Till, Falko and everyone here

    Cheer.
    ________
    KRISTALHOTXX LIVE
     
    Last edited: Aug 16, 2011
  15. kristaps

    kristaps New Member

    Hi!

    My problem is:

    server1:/usr/bin # /etc/init.d/cron stop
    Shutting down CRON daemon done
    server1:/usr/bin # pkill crond
    server1:/usr/bin # crontab -e
    crontab: installing new crontab
    server1:/usr/bin # /etc/init.d/crond start
    bash: /etc/init.d/crond: No such file or directory
    server1:/usr/bin # /etc/init.d/cron start
    Starting CRON daemon done


    I don’t know ore it’s a problem bat my crontab who’s totally empty!

    server1:/usr/bin # crontab -l
    # DO NOT EDIT THIS FILE - edit the master and reinstall.
    # (/tmp/crontab.XXXXPtm0xp installed on Mon Aug 14 17:21:53 2006)
    # (Cron version V5.0 -- $Id: crontab.c,v 1.12 2004/01/23 18:56:42 vixie Exp $)
    30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
    0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
    0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
    15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
    40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
    05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null

    THIS WILL WORK???
     
  16. falko

    falko Super Moderator

    Yes, this will work. :)
     
  17. breusz

    breusz New Member


    WRONG! The correct syntax to make it run from cron.d is:

    15 4 * * * root /root/ispconfig/php/php -c /root/ispconfig/php /root/ispconfig/scripts/shell/webalizer.php >& /dev/null

    Changes:
    - you need to provide "root" user to run as, otherwise cron won't even try to execute this job,
    - you need to give php -c, otherwise php can pickup wrong php.ini (it did for us),
    - "& >" is "run in background and redirect stdout", you need ">&" - "redirect stdout and stderr".
     
  18. falko

    falko Super Moderator

    If you run
    Code:
    crontab -e
    as root and add the cron job, you don't need to specify the root user.
     
  19. spacekeez

    spacekeez New Member

    Thanx a lot! I have the same problem. No cron job for root in Fedora 5. I followed your instructions. We will see tomorow.

    KeeZzz...
     
  20. falko

    falko Super Moderator

    This will be fixed in ISPConfig 2.2.7. Just wait a few days until it is released. :)
     

Share This Page