Webalizer issue

Discussion in 'Installation/Configuration' started by pesja, Aug 5, 2006.

  1. pesja

    pesja Member


    I have this big problem and that is that ispconfig / webalizer doesn't create a /stats directory on every new site I make and don't update the stat files.

    First I thought it had something to do with the installation of my OS (debian 3.1). So I tried another (CentOS 4.3) but stil no luck. Even with my third try (Fedora core 5) still no luck.

    For your information: Every (perfect) installation of one of the above OS-ses did go very well. With Centos and Fedora I didn't had to configure Webalizer at al, so I couldn't make any mistakes with it.

    The same with ISPConfig 2.2.5 All the installations (3 Os-ses) went smoothly and without any errors. I really don't know what the problem is?

    Off course I tried several options like pointed out in this forum (like stop cron (or crond), kill it, edit the crontab, doing nothing with it, and save it as it is.... No luck for me.

    Alright, the manual commands are working as the should be, but I want it to let it works automated.

    As I see it, 2 things can be wrong. The first is, that I doing something wrong with installation. I don't know, because I litterly follow the perfect installs of the relevant OS-ses. The second is that there is something not working 100%after the installation of ISPConfig, but I can't figured it out.

    Well, I can make a new cronjob of it, but maybe someone have the right sollution, or even more important, what's the problem with webalizer.

    Many thank's in advance.
  2. falko

    falko Super Moderator ISPConfig Developer

    The stats folders aren't created immediatley after the web site has been created. It's a cron job that runs once per day, so you might have to wait for 24 hours until a new web site has a stats folder.
  3. pesja

    pesja Member

    I checked off course the cronjobs, and everything seemed ok. I already knew that I had to wait one day or so (cronjeb webalizer runs about 4-and a little more minutes am) and I did that.

    But is still is strange that with 3 different os-ses the same problem appear. With the perfect installs everything is strait-forward and also ISPConfig installs smooth.

    The onley modification I made within the perfect install is a different IPAdress and another hostname / domainname. With this everything is running fine (www, ftp, dns etc.) except webalizer.

    Could this have something to do with the modifications ISPConfig makes within the cronjobs?
  4. Hans

    Hans Moderator ISPConfig Developer

    I know what you mean, i had the same problem.

    Give this a try:

    /etc/init.d/cron stop
    pkill cron (Make sure no cron processes are left.)
    Edit your crontab (crontab -e) and save it again.
    Then restart cron: /etc/init.d/cron start

    Wait for maximum 24 hours ...
    Last edited: Aug 7, 2006

Share This Page