Webalizer error

Discussion in 'General' started by itwillcome, Mar 13, 2012.

  1. itwillcome

    itwillcome New Member

    Hi all,

    Last week my server was shutdown because of power failure.
    And after reboot, the webalizer does not update statistics anymore.

    Now every day when webailzer runs, I get an email:

    Error: Unable to restore run data (99)

    You have old files in your logwatch tmpdir (/var/cache/logwatch):
    The directories listed above were most likely created by a
    logwatch run that failed to complete successfully. If so, you
    may delete these directories.

    I remove the tmpdir. No use.

    I tried to remove and install webalizer again. Cannot solve the problem.

    I have searched google and try suggestions like:
    # rm -f /var/www/*/web/stats/webalizer.current
    # rm -f /var/www/*/web/stats/webalizer.hist
    # /etc/cron.daily/00webalizer

    Still the same problem:
    Error: Unable to restore run data (99)

    Can anybody help?
  2. itwillcome

    itwillcome New Member

    As I can't have the webalizer working, I try to go for awstats.

    I upgrade the ISPConfig to 2.2.40, but I can't find where to enable it... :confused:

    After reading the script /root/ispconfig/scripts/shell/awstats.php ,
    I notice that I can enable certain domain to use awstats by setting webalizer_stats field to '2'.

    I want to know where this option can be set in the control panel.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You can select the statistics type for each website on the stats tab of the website settings.
  4. itwillcome

    itwillcome New Member

    Hi Till,

    Thanks for the reply.

    But in the statistics tab on both ISP Client and ISP Site,
    it shows the traffic statistics only.
    There is no option can be set.

    Stats tab of ISP Client: [​IMG]

    Stats tab of ISP Site: [​IMG]
  5. jnsc

    jnsc rotaredoM Moderator

    It's the last entry of the Options tab.
  6. itwillcome

    itwillcome New Member

    Thanks jnsc.

    But in my options tab:

    The last entry is just a checkbox.

    Check it will make the webalizer_stats field to '1'.
    Uncheck it will make the field to '0'.
    Never '2' ... :confused:
  7. jnsc

    jnsc rotaredoM Moderator

    It should look like this

    Did you had an error during update? it look like your update went wrong

    do you have this
    ### AWStats Section ### 
    Alias /icon "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/" 
    ### End of AWStats Section ###
    in your /etc/apache2/apache2.conf
  8. itwillcome

    itwillcome New Member

    I don't have any error during update.
    My options tab is not as yours. :(

    Only a checkbox for "webalizer stats". (version 2.2.40)


    # tail -n 3 /etc/httpd/conf/httpd.conf
    ### ISPC AWStats Section ###
    Alias /awstatsicons "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/"
    ### End of ISPC AWStats Section ###

    I think there are some problems of my version of ISPConfig...
    I'll try reinstall ISPConfig later. Thanks for your kindly help, jnsc.

Share This Page