Webalizer error

Discussion in 'Installation/Configuration' started by toyito, Jan 26, 2006.

  1. toyito

    toyito New Member

    Im having problems whit webalizer...reading some posts about a found this code:

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php

    Whe i runnit i get:

    Warning: readlink(): Invalid argument in /root/ispconfig/scripts/shell/logs.php on line 125

    is this the problem??? what can i do

    Regards
    Hector
     
  2. till

    till Super Moderator

    Which problems do you have with webalizer?

    Thats just a warning that does not matter. It wont stop the script.

    The script /root/ispconfig/scripts/shell/logs.php splits the logfiles, the webalizer script is: /root/ispconfig/scripts/shell/webalizer.php and can be called with:

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php
     
  3. toyito

    toyito New Member

    Thanks Till

    My problem is that i cant see the stats on the web...i point to http://www.xxx.com/stats and i get a 404 error page

    Hector
     
  4. falko

    falko Super Moderator

  5. hairydog2

    hairydog2 New Member

    Just to help me with a related problem, do you have a directory called 'localhost' in your /home/www directory? I do, and I get that error message unless I do some tweaking.
     
  6. toyito

    toyito New Member

    Hi

    under /home/ i dont have a "www" folder

    Hector.

    Thanks Falko, i follow the steps in that thread, do i need to wait until 4:00 am?, there´s no way to to see if the problem was fixed??

    Hector
     
    Last edited: Jan 26, 2006
  7. falko

    falko Super Moderator

    Yes, you must wait...
     
  8. toyito

    toyito New Member

    Thanks a lot....as i told you I foolowed the steps on thread and now all is runnig ok

    Thank you Falko

    Regards
    Hector
     
  9. sulfuric

    sulfuric ISPConfig Developer

    Related probem

    Im having problems whit webalizer...reading some posts about a found this code:

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php
    /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizar.php

    I could create my stats manually.

    CRON don't execute this at 0,00-4,00, I can create my stats manually only.

    I try to stop CRON, edit CRON (crontab-e) and then save and start, but don't work, only a extrange meesage on syslog

    Mar 9 02:09:02 omaxserver /USR/SBIN/CRON[15263]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
    Mar 9 02:09:02 omaxserver /USR/SBIN/CRON[15265]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
    Mar 9 02:17:01 omaxserver /USR/SBIN/CRON[15474]: (root) CMD ( run-parts --report /etc/cron.hourly)
    Mar 9 02:31:58 omaxserver -- MARK --
    Mar 9 02:39:01 omaxserver /USR/SBIN/CRON[16005]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
    Mar 9 02:39:01 omaxserver /USR/SBIN/CRON[16006]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
    Mar 9 02:51:58 omaxserver -- MARK --
    Mar 9 03:09:01 omaxserver /USR/SBIN/CRON[16742]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
    Mar 9 03:09:01 omaxserver /USR/SBIN/CRON[16744]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
    Mar 9 03:17:01 omaxserver /USR/SBIN/CRON[16952]: (root) CMD ( run-parts --report /etc/cron.hourly)
    Mar 9 03:31:58 omaxserver -- MARK --
    Mar 9 03:39:01 omaxserver /USR/SBIN/CRON[17482]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
    Mar 9 03:39:01 omaxserver /USR/SBIN/CRON[17484]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
    Mar 9 03:51:58 omaxserver -- MARK --
    Mar 9 04:09:01 omaxserver /USR/SBIN/CRON[18221]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
    Mar 9 04:09:01 omaxserver /USR/SBIN/CRON[18223]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
    Mar 9 04:17:01 omaxserver /USR/SBIN/CRON[18432]: (root) CMD ( run-parts --report /etc/cron.hourly)
    Mar 9 04:31:58 omaxserver -- MARK --

    it's the error, I have perfect setup Ubuntu breeze on AMD 64.

    Thanks
     
  10. falko

    falko Super Moderator

    Did you run
    Code:
    crontab -e
    as root?
     
  11. sulfuric

    sulfuric ISPConfig Developer

    yes i did it

    content of crontab

    15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
    40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
    05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null
    30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
    0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
    0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null

    then restart, no errors
     
  12. sulfuric

    sulfuric ISPConfig Developer

    And one warnig

    Warning: readlink(): Invalid argument in /root/ispconfig/scripts/shell/logs.php on line 125
     
  13. falko

    falko Super Moderator

    Your output of
    Code:
    crontab -e
    is ok, but it's strange that there's nothing in the syslog about the cron jobs - as if they didn't run at all...:confused:
     
  14. sulfuric

    sulfuric ISPConfig Developer

    crontab -e:

    15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
    40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
    05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null
    30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
    0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
    0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null

    I thinking update to ispconfig 2, this might resolve the problem.

    Update is supported for amd64
     
  15. till

    till Super Moderator

    The updater does not reconfigure your cronjobs, so I'am not sure if it can fix your problem. But the update might be a good idea anyway :)

    Yes. ISPConfig 2.2.0 is the first relaese with official amd64 support without having to modify the compile scripts.
     

Share This Page