webalizer: Error: Can't open log file /var/www/web34/log/web.log (symlink)

Discussion in 'Installation/Configuration' started by olasamuelson, Jan 12, 2010.

  1. olasamuelson

    olasamuelson New Member

    Hi all!
    Been like this for a while. I simply cant reinstall must fix. To many domains.
    Any clue as to why this happens(now, worked before update some time ago)?

    Software: 2.2.33 on f11
    Everything works but 403 on "stats".

    Here is what i have checked:
    - which webalizer gives:/usr/bin/webalizer
    - i can run /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php
    and it gives lines like"webalizer: Error: Can't open log file /var/www/web34/log/web.log (symlink)"

    - ssh to machine as root: i can read/open all of the files webalizer complains about.
    They are up to date with log entries. So logs are written.
    - ls -la /var/www gives 755 on all directories owner: domain admin and group
    is webxx. same on /var/www/webxx/log and "stats" directory
    - 775 on subdirs below /var/www/webxx. havent changed that since it worked,
    - can access log file both via webxx/log/web.log and via /var/www/domain.se/log/web.log

    - webalizer exists
    - webalizer finds config
    - web.log symlink is there
    - web.log is looks properly linked
    - target log file is readable and not empty
    - permissions "look ok". right?

    - since files are not found no content to "stats" is written.

    On the other hand:
    - should i not be able to see "old" stats instead of a 403?
    There are older stats with perms 755 owned by domain.se_admin:webxx

    Two errors?

    1. webalizer not following symlink for some reason
    2. stats url not properly set up

    More ideas?
  2. olasamuelson

    olasamuelson New Member

    More info:
    in /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf for the domains i have(which worked before):
    Alias /stats "/var/www/web30/web/webalizer"

    Ok, part of the problem lies here. In this directory is only the .htaccess file. Actual webalizer
    content is in "/var/www/web30/web/stats". The old version put it here.

    If i change to /var/www/web30/web/stats i get the old stats. Ok no more 403.

    Two problems remain:
    1. No .htaccess file in "stats". Question: should it reside in "webalizer" or "stats"?
    Can i simply move it to "stats" and change all stat entries in Vhosts_ispconfig.conf to "stats"?
    2. Still, webalizer can't read the files i can read so no new stats.

    I have no problem changing the configs but i would like to know what is the new(right) way
    to do this. Should stats point to stats or to webalizer and what about the .htaccess file?
  3. olasamuelson

    olasamuelson New Member

    ok, checked time of .htaccess file. Webalizer recreates it so the webalizer directory is the correct one. First problem remains, webalizer can not read/follow web.log symlink.
    It is there, points to actual data.
  4. olasamuelson

    olasamuelson New Member

    All this must be due to update. Old behaviour was to write to "stats" directory and newer to "webalizer". Sounds logical? Maybe the webalizer conf/scripts was not updated?
  5. olasamuelson

    olasamuelson New Member

    Directories are now ok...i think.
    Updated to 2.2.35, more errors running webalizer but lets forget that for a moment.
    Deleted the webalizer dirs on all domains, ran webalizer.
    All old dirs migrated, no 403, new htaccess. So that is solved BUT
    still symlink errors from webalizer trying to read logs.
    I saw somewhere something about compiled in "symlink protection", what is that, could it be the problem, can/should i turn it off? If not, what is the solution?
  6. olasamuelson

    olasamuelson New Member

    Backing up to older webalizer solved everything for now. I'll have to see what happens when the cron job has run. But it all looks as if it is working. I installed:
    Webalizer V2.01-10 (Linux English

    which reads all symlinks and does not complain about directories.

Share This Page