webalizer 403 Forbidden

Discussion in 'General' started by angelbulas, May 26, 2009.

  1. angelbulas

    angelbulas New Member

    Hi, i don't know if someone can help me, I have ISPConfig version 3.0.1.1, and when I try to access to http://mydomain.tld/stats I put my username (admin) and my password (I configured it in Sites>Domain>Statistics) but then my web browser send me the following message:

    Forbidden

    You don't have permission to access /stats/ on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    And in the logs at /var/log/ispconfig/httpd/mydomain.tld/error.log I notice the following two lines:

    [Mon May 25 18:17:56 2009] [error] [client 1.2.3.4] Directory index forbidden by Options directive: /var/www/mydomain.tld/web/stats/
    [Mon May 25 18:17:56 2009] [error] [client 1.2.3.4] File does not exist: /var/www/error/403.html

    Did someone know what is the problem, I try to access /var/www/mydomain.tld/web/stats and the directory is empty, only the file .htaccess is present and have the following lines:

    AuthType Basic
    AuthName "Members Only"
    AuthUserFile /var/www/clients/client5/web12/.htpasswd_stats
    <limit GET PUT POST>
    require valid-user
    </limit>

    I appreciate your help, thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The statistics are created nightly, you have to wait up to 24 hours until you can access them.
     
  3. angelbulas

    angelbulas New Member

    Thanks for the quick reply, I forgot to tell you that I create my site 5 days ago and I still don't see statistics about it. Does the folder /var/www/mydomain.tld/web/stats should have any file? because I only have the .htaccess in that folder, thanks in advance
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you have the webalizer package of your linux distribution installed.
     
  5. angelbulas

    angelbulas New Member

    yes, i have this version installed:
    webalizer - 2.01_10-30.1.i386

    What other thing it might be? I have CentOS 5.2 installed, thanks for your help
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    getenforce
    and
    Code:
    which webalizer
    ?
     
  7. angelbulas

    angelbulas New Member

    # getenforce
    Disabled
    # which webalizer
    /usr/bin/webalizer
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /etc | grep webalizer
     
  9. angelbulas

    angelbulas New Member

    # ls -la /etc | grep webalizer
    -rw-r--r-- 1 root root 23735 Jan 8 2007 webalizer.conf

    This are the uncommented lines in the file webalizer.conf :

    LogFile /var/log/httpd/access_log
    OutputDir /var/www/usage
    HistoryName /var/lib/webalizer/webalizer.hist
    Incremental yes
    IncrementalName /var/lib/webalizer/webalizer.current
    PageType htm*
    PageType cgi
    PageType php
    PageType shtml
    DNSCache /var/lib/webalizer/dns_cache.db
    DNSChildren 10
    Quiet yes
    FoldSeqErr yes
    HideURL *.gif
    HideURL *.GIF
    HideURL *.jpg
    HideURL *.JPG
    HideURL *.png
    HideURL *.PNG
    HideURL *.ra
    SearchEngine yahoo.com p=
    SearchEngine altavista.com q=
    SearchEngine google.com q=
    SearchEngine eureka.com q=
    SearchEngine lycos.com query=
    SearchEngine hotbot.com MT=
    SearchEngine msn.com MT=
    SearchEngine infoseek.com qt=
    SearchEngine webcrawler searchText=
    SearchEngine excite search=
    SearchEngine netscape.com search=
    SearchEngine mamma.com query=
    SearchEngine alltheweb.com query=
    SearchEngine northernlight.com qr=
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    mkdir /etc/webalizer
    ln -s /etc/webalizer.conf /etc/webalizer/webalizer.conf

    and wait until tomorrow to see if the stats get created.
     
  11. angelbulas

    angelbulas New Member

    Thanks, i'm gonna do that and tomorrow I will check it out an I will let you know, thank you so much for your help.
     
  12. angelbulas

    angelbulas New Member

    I check my webpage but I still can't see any stats yet :( , do you have another idea? thanks
     
  13. robertlouwen

    robertlouwen New Member

    @ Angelbulas

    I am also strugling with stats and looked around in several directories and found this:
    In /etc/httpd/conf.d I found "webalizer.conf" then I vi-edit webalizer.conf and saw on the first line : Alias /usage /var/www/usage.

    On my windows machine I go to www.something.org/usage/ and no login popup just a page with statistics about traffic and so on.

    Don't ask me how ...
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    This file is not in use on a ISPConfig setup and you will not get any website stats with it!

    The URL to get stats on a ispconfig server is www.yourdomain.tld/stats/
     
  15. robertlouwen

    robertlouwen New Member

    @ Till,

    I don't want to be rude but out of curiosity why is in the file /etc/httpd/conf.d/webalizer.conf Alias /usage /var/www/usage ?

    I am only a dummy to ispconfig but I like it every day a little more and want to learn as much as possible.

    Please see attached images for something.nu/usage.
     

    Attached Files:

  16. till

    till Super Moderator Staff Member ISPConfig Developer

    This file is not from ISPConfig.
     
  17. robertlouwen

    robertlouwen New Member

    @ Till, I looked at the tut. "perfect server.." and "webalizer" get's installed according to page 5 point 19.
     
  18. The-Ghost

    The-Ghost New Member

    I can allso not acces the stats.
    When I go to www.domain.tld/stats it's asking for a username and password.
    When I fill in the client name and the stats password, it comes again with the request for login.

    Is there soething I do wrong???

    Regards Carlo
     
  19. angelbulas

    angelbulas New Member

    you have to go to your control panel, click on "Sites" and then click in the site that you want to enable statistics, then click on "Stats" and set a password. The user is always "admin" and the password is the one that you set, then you can login. I still can't see my statistics, i hope you do. regards
     
  20. baskin

    baskin New Member

    I have a similar problem.

    I cannot access the stats page (403 error) after installing "Drupal" on the site and enabled drupal's .htaccess file on the root directory of the site.

    Before installing drupal, i was able to access the stats page normally.

    I'm not sure if this happened after the installation of drupal, but i suspect the new .htaccess file.

    What should i check?
     

Share This Page