web site creation

Discussion in 'Installation/Configuration' started by icemannz, Apr 25, 2010.

  1. icemannz

    icemannz New Member

    Hi all, I am new to ISPConfig so please excuse the basic question.
    I have the server all setup and running ISPConfig3 (Debian) from the guides.
    The email seems to be working.
    I created a new client - lets call him bob.
    So I have now created a new web site - lets call it pcsite1.com and put in the client name bob.
    Under the Autosubdomain I selected www
    Then I created a new FTP user - I am a bit unsure of what to put under [Clientname], So I put in bob.
    I also set my host file on my windows box up so that it has the address of my ISPConfig box listed with the domain name.
    When I try to browse to the domain name I only get the default page saying "It Works".
    When I FTP in and see the web directory, I delete the index.htm and put in a new one, but I still only see the default page "It Works" when I browse to it.

    I then also setup the DNS on ISPConfig for the domain name and put an A record for www and pointed it to my local ip address. (just testing locally).
    Can anyone please tell me what I am doing wrong ?
    Basically I am not seeing what the index.htm is saying - I am just getting redirected to the default page I believe.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Select the IP address where you pointed the domain to in the website settings instead of *
     
  3. icemannz

    icemannz New Member

    Thanks for your reply Till,
    But it only has the * in the box for the ip address,
    how do I add it to the system so that it will show up in that box ?
     
  4. natelabo

    natelabo New Member

    You go into System Tab in ispconfig
    Then Server IP addresses
    Here you add the local ip of the server. Not your external IP. Save.
    Then go back to the site and it will be available to select.
     
  5. icemannz

    icemannz New Member

    Hi all,
    I have done as you have said and put in the local ip address.
    Added it and then put it into the site instead of the *,
    but I still have the same issue.
    When I go to the site it just shows the default page of "It Works".
    Any more suggestions ?
     
  6. natelabo

    natelabo New Member

    Try giving it a little time... I had to wait about two hours and then everything starting showing up correctly.
     
  7. icemannz

    icemannz New Member

    Hi all,
    I have made some progress but still need some help on why this happened.
    Basically I have renamed the web site pcsite1.com,
    it was pcsite1.co.nz.
    Now as a .com web site it works correctly,
    so can someone tell me why it doesn't work as a .co.nz web site.
    This is an issue for us as most of our web sites are .co.nz
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The domain ensing does not matter for ispconfig. You can use domain tld that you ike. If it did not worked for co.nz, then the DNS was not correct for that domain. Be aware that changes in DNS may take up to 48 hours.
     

Share This Page