Web Server - Offline

Discussion in 'Server Operation' started by willebanks, Sep 8, 2006.

  1. willebanks

    willebanks New Member

    This is a wierd one Guys...

    I was just looking around my ISPConfig and I noticed that the webserver was offline! When I checked Apache it was fine...and my hosts are up. Not should what I should do or if I need to do anything? Any ideas? :confused:

    Will
     
  2. edge

    edge Active Member Moderator

    Are you maybe running apache on an other port than 80?
     
  3. willebanks

    willebanks New Member

    Nope..thats whats so weird about this I have made only a minor change to the vhosts file and when I restarted hhtpd no errors jumped out everything started..all my hosted pages are up and running...the only thing that I just noticed is I can't make any changes within ISPConfig that need to be saved. I get this error,

    "Your changes cannot be saved because this item is currently being updated. Please try again later."

    Just to see if I created the problem I changed the vhosts file back and restarted httpd and then the whole system...nothing changed but the vhosts file. This is just weird!

    Will
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    ls -la /root/ispconfig
    ? Which distribution do you use?
     
  5. willebanks

    willebanks New Member

    Sorry I did get back to this sooner...Had a death in the family and had to go out of town!

    Falko...

    I'm using Fedora Core 5.

    Output of ls -la /root/ispconfig:

    total 104
    drwxr-xr-x 9 root root 4096 Sep 3 17:02 .
    drwxr-x--- 24 root root 4096 Sep 13 16:47 ..
    -rwxr-xr-x 1 root root 33120 Jul 27 05:39 cronolog
    -rwxr-xr-x 1 root root 9673 Jul 27 05:39 cronosplit
    drwxr-xr-x 12 root root 4096 Jul 26 21:07 httpd
    drwxr-xr-x 12 root root 4096 Jul 27 05:39 isp
    -rw-r--r-- 1 root root 0 Sep 8 21:27 .ispconfig_lock
    -rw-r--r-- 1 root root 8 Sep 3 17:02 .old_path_httpd_root
    drwxr-xr-x 6 root root 4096 Jul 26 20:58 openssl
    drwxr-xr-x 6 root root 4096 Jul 26 21:12 php
    drwxr-xr-x 4 root root 4096 Jul 27 05:39 scripts
    drwxr-xr-x 4 root root 4096 Jul 27 05:39 standard_cgis
    drwxr-xr-x 2 root root 4096 Jul 27 05:39 sv
    -rwx------ 1 root root 9389 Jul 27 05:39 uninstall

    Output of netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 1766/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1448/portmap
    tcp 0 0 192.168.2.100:http *:* LISTEN 3770/httpd
    tcp 0 0 *:hosts2-ns *:* LISTEN 3747/ispconfig_http
    tcp 0 0 192.168.2.101:domain *:* LISTEN 3866/named
    tcp 0 0 192.168.2.100:domain *:* LISTEN 3866/named
    tcp 0 0 server1.alternativec:domain *:* LISTEN 3866/named
    tcp 0 0 *:smtp *:* LISTEN 26188/master
    tcp 0 0 server1.alternativecom:rndc *:* LISTEN 3866/named
    tcp 0 0 *:54557 *:* LISTEN 1467/rpc.statd
    tcp 0 0 192.168.2.100:57946 a204-60-219-175.deploy:http ESTABLISHED 14844/firefox-bin
    tcp 0 0 192.168.2.100:57930 a204-60-219-175.deploy:http TIME_WAIT -
    tcp 0 0 192.168.2.100:57927 a204-60-219-175.deploy:http TIME_WAIT -
    tcp 0 0 192.168.2.100:http dex-252-16.dxi.net:btrieve TIME_WAIT -
    tcp 0 0 192.168.2.100:48984 209.170.113.31:http TIME_WAIT -
    tcp 0 0 192.168.2.100:53086 a204-60-219-168.deploy:http TIME_WAIT -
    tcp 0 0 192.168.2.100:47057 208.67.80.27:http ESTABLISHED 3889/freshclam
    tcp 0 0 192.168.2.100:47454 a204-60-219-168.deploy:http TIME_WAIT -
    tcp 0 0 192.168.2.100:42705 a204-60-219-170.deploy:http TIME_WAIT -
    tcp 0 0 *:imaps *:* LISTEN 1794/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 1794/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 1794/dovecot
    tcp 0 0 *:imap *:* LISTEN 1794/dovecot
    tcp 0 0 *:ftp *:* LISTEN 3883/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 1657/sshd
    tcp 0 0 ::1:rndc *:* LISTEN 3866/named
    tcp 0 0 *:https *:* LISTEN 3770/httpd

    Hope this helps!
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    rm -f /root/ispconfig/.ispconfig_lock
    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    What's the output?
     
  7. willebanks

    willebanks New Member

    Here you go Falko;

    PHP Notice: Undefined variable: HTTP_GET_VARS in /home/admispconfig/ispconfig/lib/config.inc.php on line 32
    PHP Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/lib/config.inc.php on line 32
    PHP Notice: Undefined variable: HTTP_POST_VARS in /home/admispconfig/ispconfig/lib/config.inc.php on line 38
    PHP Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/lib/config.inc.php on line 38
    PHP Notice: Undefined variable: HTTP_COOKIE_VARS in /home/admispconfig/ispconfig/lib/config.inc.php on line 44
    PHP Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/lib/config.inc.php on line 44
    PHP Notice: Undefined variable: HTTP_GET_VARS in /home/admispconfig/ispconfig/lib/config.inc.php on line 53
    sh: httpd: command not found
    ls: /conf.d/*.conf: No such file or directory
    sh: httpd: command not found
    start
    PHP Notice: Undefined variable: find in /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php on line 657
    Segmentation fault

    Not sure if I ran the second part of the code right...Should I have ran the code as 1 whole command or was it in 2 parts...sorry just making sure I'm doin it right!
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    which httpd
    ?
     
  9. willebanks

    willebanks New Member

    falko

    here ya go:

    /usr/bin/httpd

    hope it helps
     
  10. falko

    falko Super Moderator ISPConfig Developer

    That's strange. You're running Fedora, right? Please run
    Code:
    chmod 755 /var/named/
    chmod 775 /var/named/chroot/
    chmod 775 /var/named/chroot/var/
    chmod 775 /var/named/chroot/var/named/
    chmod 775 /var/named/chroot/var/run/
    chmod 777 /var/named/chroot/var/run/named/
    cd /var/named/chroot/var/named/
    ln -s ../../ chroot
    and make sure server_bind_zonefiles_dir in the isp_server table holds the correct value: http://www.howtoforge.com/forums/showthread.php?t=1537&highlight=server_bind_zonefile_dir
    http://www.howtoforge.com/forums/showthread.php?t=5732&highlight=server_bind_zonefile_dir
     
  11. willebanks

    willebanks New Member

    Because I was having other issues I decided to re-install everything! I due have another question. What is the best way to backup most or all data on my linux box so I can recover as quickly as possible. I should've been doing this from day one and probably could have avoided this mess in the first place!

    Will
     
  12. falko

    falko Super Moderator ISPConfig Developer

Share This Page