Web-server is Offline and wont restart

Discussion in 'Installation/Configuration' started by Boon-Dog-Danny, Aug 19, 2006.

  1. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    Web-server is Offline
    if I try and restart it it says its already being updated .. its said that for two days now.. and I cant get this to come up again.. everything was fine then the web server went south.. tried reading all the forums and nothing really addresss it.. how can I get this restarted?

    everything else is still working.. e-mail.. ftp.. the admin panel.. just no site
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    could you check your error / access log of the apache (not the ISPCOnfig's one!). If you do not find anything helpfull there, edit the apaches config (httpd.conf or apache.conf etc. depends on your distro), search for LogLevel and set it to debug. The try stopping and starting it directly from the console. Either you will see errormessages directly or more detailed written to the error / debuglog.

    Anyway you can check if you find anything listening on port 80 with
    netstat -tap
    and take a look of your processes with e.g.
    ps aux | grep apache
    or
    ps aux | grep http
    to see if your apache is running and just misconfigured or does not come up.

    Maybe you will also find sth. in /home/admispconfig/ispconfig/ispconfig.log
     
  3. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    ok suse 10.1

    the perfect setup

    where do I find the error.. access and apache2 logs?

    I think I'm being ddos ed and these logs will help me as well
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    /var/log/

    Please post the output of the command:

    httpd -t
     

Share This Page