Web Server FedoraCore4 issue

Discussion in 'Installation/Configuration' started by educandote, Jan 12, 2006.

  1. educandote

    educandote New Member

    Hi there, am looking for some guidance about a webserver, I got some issues displaying home page and some folders.

    When I get to http://localhost it goes to a page, but no colors are display correctly only text, and also when I try to access a folder to install a lms platform I got
    "Forbidden
    You don't have permission to access /evirtual on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.54 (Fedora) Server at elicop Port 80"

    even I have set chown apache:apache /var/www/html/ and /var/www/html/folder but with no result.

    Mysql is running fine just that issue and am stuck there!!!

    Thanks in advance

    Eli-:(
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What kind of page is it? What's it saying? Is it maybe Fedora's default placeholder page?

    Please put an index file into the directory you're trying to access, like index.html or index.php. Or enable DirectoryListing in your Apache configuration.
     
  3. cybereatl

    cybereatl New Member

    Hi there, I got same issue, but I don't know what commands use to enable directoryListing.

    elicop
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You must put
    Code:
    Options +Indexes
    into the Directory section of the appropriate directory in your main Apache configuration file.

    E.g., if you want to enable directory listings in /var/www, and you see a section like this:

    Code:
    <Directory /var/www>
      ..
    </Directory>
    then change this section:
    Code:
    <Directory /var/www>
      [B][COLOR="Red"]Options +Indexes[/COLOR][/B]
      ..
    </Directory>
    and restart Apache.
     
  5. cybereatl

    cybereatl New Member

    Hi there I just did it, but no results!!! Still unable so see images and also to access folder!!!

    When I try to access another page I got:

    You don't have permission to access /videos on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    What else should be done, so far I got a webserver with public ip and also how can I set the mail server using this same domain??
     
    Last edited: Jan 16, 2006
  6. cybereatl

    cybereatl New Member

    How do I enable index.php access

    Hi it seems to be that index.php is not enable it, because I create a folder and I was able to access on it, but as far as I put the files and index.php I got the error.


    Thanks
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Can you be more precise? What exactly is happening?
     
  8. cybereatl

    cybereatl New Member

    Ok, what happening is this:

    WebServer is running ok on http://localhost or http://ipaddress both ways Apache server is running.

    As soon as I add a graphic to .html file is not showing --

    When I create a folder in order to install a program shows up folder content but as soon as I copy those files with exdex.php I got error:

    -- You don't have permission to access /lms on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.--

    The lms got a index.php file in order to install but for some reason when Itype in is giving that error!!!

    What can I do, got get access up and running, also how apahce file how must be????

    Thank you
     
    Last edited: Jan 17, 2006
  9. falko

    falko Super Moderator ISPConfig Developer

    Please post the output of
    Code:
    ls -la /path/to/your/web_folder
     
  10. cybereatl

    cybereatl New Member

    Solved

    Thank you for helping me out Falko, It was an issue with domain resolving who was pointed to other ip address and wasn't allowing server to display
    # dig domainnem.info xxx.xx.xxx.206

    Thanks a lot
     

Share This Page