[web server] domain with alias to system application does not render php.

Discussion in 'Installation/Configuration' started by pootle, Nov 10, 2010.

  1. pootle

    pootle New Member

    I have a domain which references an application on the system that serves out php pages.

    it resides under /usr/share/webapp . Php works perfectly fine under my users accounts and any php under the web directory of the client works fine. However when the alias is invoked the php page downloads as if nothing was configured :/

    I've tried adding :

    <IfModule mod_suphp.c>
    suPHP_Engine on
    # suPHP_UserGroup web2 client1
    AddHandler x-httpd-suphp .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-suphp

    to the alias directory but I still get the same result... If I configure the site outside of ISPConfig control it'll work perfectly fine but I didn't want to do this as this app can be used by more than one user and it'll defeat the object of using ISPConfig.

    I know I've missed something obvious but can anyone help here?
  2. pootle

    pootle New Member

    ignore this i worked it out!

    tiredness is not my friend and it's been a while since I last looked at a webserver config

    the solution is not to use suphp for this alias but to use modphp instead. My chrome seemed to cache the page longer ( even on full refresh ) than firefox and when I ran it in firefox I got a script error which indicated the ownership for the script was wrong. Seeing as multiple users can reference this app the solution is not to use suphp and use modphp or something else instead.

    works now

    <Directory /usr/share/webapp/>

    DirectoryIndex index.php
    Options -Indexes +FollowSymLinks
    AllowOverride Options
    Order allow,deny
    AddType application/x-httpd-php .php .php3 .php4 .php5


Share This Page