Web Quota does not count

Discussion in 'General' started by Moundy, May 20, 2012.

  1. Moundy

    Moundy New Member

  2. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Are you within an OpenVZ container?
    Then quota mostly won't work.
     
  3. theWeird

    theWeird Member

    I had the same problem on my ISP-installations inside an OpenVZ container.

    It is a bug in an older openvz-kernel on the host node which has been fixed some month ago. But because openvz is developed on a redhat kernel the patches need really long time to be ported into the official debian kernel.

    But the people of the Proxmox project work much faster on that point than the debian devs.
    I switched the kernel used on the host node to Proxmox (which is based on debian) and now all problems I had with openVZ disappeared.

    Just follow the steps
    'Adapt your sources.list' and 'Install Proxmox VE Kernel'
    on this wiki page to make it work like a charm.
    http://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Squeeze

    BUT:
    If you already had VEs configurated:
    Proxmox moves the directory /etc/vz/conf to /etc/vz/conf.org and creates a symlink from /etc/vz/conf to /etc/pve/openvz.
    So after installing Proxmox VE it seems that all your VEs are gone.
    Just copy the config files from conf.org back to conf and restart openvz
    # /etc/init.d/vz restart
    Afterwards everything is fine.

    My original post in the german forum:
    http://www.howtoforge.de/forum/29686-post23.html
     
  4. Moundy

    Moundy New Member

    Hi,

    I'm using a full dedicated Server with no virtuallisation but i have Migrated my ispconfig a few Day ago to this Server and i have cleared the Logs Maybe to much cleared or could a disabled php function be a Problem?
     
  5. Moundy

    Moundy New Member

    Edit: The Quota is still empty also if i add values in the monitor data. After a few minuten all in empty.
     
    Last edited: May 22, 2012
  6. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Did you install quota & quotatool (or quotatools, not sure) and edit the /etc/fstab like described in the tutorials here?
     
  7. Moundy

    Moundy New Member

    Hi,

    the discribed Install Script seems to has not installed the Quota right, becouse the fstab is not edited.

    I have found (https://gist.github.com/2016010)
    After i insert UUID=92bceda2-5ae4-4e3a-8748-b14da48fb297 / ext3 errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 1 the command "quotacheck -avugm" works fine.

    Before the change just this appears: quotacheck: Kann kein Dateisystem zum Prüfen finden oder Dateisystem nicht mit der Quota-Option gemountet. (translated: quotacheck: Can not find filesystem to check or filesystem not mounted with quota option.)

    Now my fstab looks like:

    Is that a good soulotion?

    The output of quotacheck -avugm was:

    In english:

     
  8. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Not sure if your fstab is 100% correctly, but as far as I see (check out this: http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-dovecot-ispconfig-3-p4, point 13) it should more look something like:

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc	 /proc	 proc	defaults	0	0
    /dev/md1	/	 ext3 errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0	0	1
    /dev/md0	/boot	 ext2	defaults	0	2
    /dev/sda2	none	 swap	sw	 0	0
    /dev/sdb2	none	 swap	sw	 0	0
    And do not forget to run these commands:

    mount -o remount /
    quotacheck -avugm
    quotaon -avug
     
    Last edited: May 23, 2012
  9. Moundy

    Moundy New Member

    MaddinXx, thank you very much now it works :)

    My idea was just stupid :D

    It counts now perfect but shows on every user "unlimited".

    Edit: After waiting a few Minutes (around 20 minutes) now it all works perfekt!

    Thank you very very much!
     
    Last edited: May 23, 2012
  10. mkz

    mkz New Member

    I have a problem. I install on multiserver. when try execute:

    sudo mount -o remount /

    see:

    mount: / not mounted or is it a wrong choice

    mi /etc/fstab

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    nodev,noexec,nosuid 0       0
    /dev/mapper/web03-root /               ext4     errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0      0       1
    # /boot was on /dev/sda1 during installation
    UUID=f4da54ac-0bd7-4035-91c5-f941ca1bffc0 /boot           ext2    defaults        0       2
    /dev/mapper/web03-swap_1 none            swap    sw              0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
    
    thanks.
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Have you tried to reboot? That should fix it.
     
  12. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Hi

    I just tried switching to the Proxmox kernel, but the system won't boot anymore...

    1) What could have been gone wrong?
    2) I have access to a rescue system where I can mount all partitions e.g. /dev/md1 etc. - how can I revert to the old kernel so it can boot up again?

    //edit: OK I was able to boot with the old kernel, but still it would be cool to know what went wrong :)

    Would really appreciate your help :)
     
    Last edited: Aug 8, 2012

Share This Page