Web Mail

Discussion in 'General' started by mphayesuk, Sep 14, 2005.

  1. mphayesuk

    mphayesuk New Member

    Ok I have pointed a domain name to the mail server I can send e-mail from web mail no problem but I cant send mail to it. Dont know why.....

    One point to mention is that when suse is starting up I get a warning that postfix is trying to start on ip xxx and port 21 but proftpd is already started on that ip and port "(default installation)". Is this part of the problem and if so how do I fix it, if not how do I fix it anyway.

    One final question where would the mail logs be kept if I did a default installation.

  2. falko

    falko Super Moderator ISPConfig Developer

    This is a huge problem. Postfix should run on port 25. Please have a look at /etc/postfix/main.cf.

    On SuSE it's /var/log/mail (I think...).
  3. mphayesuk

    mphayesuk New Member

    OK cant find anything in the conf file for any port of ip settings, if you want I can post the file on here and you can look, incase I missed something.

    Is there anything else I can try...

    I am sure that when I installed it I did the check when you connect to localhost on port 25.... not sure of the command now but I did that and it worked.

  4. mphayesuk

    mphayesuk New Member

    Fixed the port problem I now get no errors when the server starts, which is a good thing, but I still cant send emails to the server...... emails are going out ok but just not coming in.

    Any suggestons anyone....
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you get any errors in the mail logs?

    Did you select the correct mailstorage format for your setup in ISPConfig (Maildir or Mbox)? If you are not shure waht to select, just change it and send an email to see if it arrives.
  6. mphayesuk

    mphayesuk New Member

    Where do I change that setting again???
  7. falko

    falko Super Moderator ISPConfig Developer

    Under Management -> Server -> Settings -> Email.
  8. mphayesuk

    mphayesuk New Member

    Ok changed the dir --- no change

    so the maildir is now unchecked

    anything else I can try
  9. falko

    falko Super Moderator ISPConfig Developer

    I've sent you a private message. Maybe I can help you but I need to login on your system to see what's going on. :)
    Last edited: Sep 15, 2005
  10. mphayesuk

    mphayesuk New Member

    Ok so any more suggestions on what to try next..
  11. falko

    falko Super Moderator ISPConfig Developer

    You could have a real-time look at your mail log while you're sending a mail to the server:

    tail -f /var/log/mail.log
    (Don't know what distribution you use; on Debian it's /var/log/mail.log, on other distributions it's different, e.g. /var/log/mail.)

Share This Page