Web-FTP - Left frame opens, right frame does not.

Discussion in 'Installation/Configuration' started by tarndt, Aug 16, 2006.

  1. tarndt

    tarndt New Member

    OK, so third install of ISPConfig, everything seemed to run great for the first 3 days, then all my "web#_user" could not log in this morning. I tried to uncheck the FTP check box and recheck it, which did not work, I then removing one of the users which still didn't work. Finally I rebooted and hey...That's all it needed. HOWEVER, when I recovered the user I deleted from the Recycle bin, he is the only one who can't use Web-FTP now. The left pane opens, the right pane provides the error:
    Warning: include(/home/admispconfig/ispconfig/web//lib/module.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 240
    Warning: include() [function.include]: Failed opening '/home/admispconfig/ispconfig/web//lib/module.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 240
    Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/web/isp_file/frame_start.php on line 118
    I looked at the session.inc.php file on the indicated lines and it appears as though the $go_info["server"]["dir_trenner"] = '/'; variable stays set to '/' and thus produces my error.

    I have three possible solutions and would like to know if they can be performed (I ordered them from most desirable solution to least).

    1. There must be information missing somewhere, I just don't know where, if someone knows, I would like to enter the information manually whether it be in a DB or permissions for a file/dir, etc.

    2. Remove the user and re-add them (Can I add the same user after removing the deleted user from the Recycle Bin?)

    3. Move all files from the published web folder to another directory, Create a new user make them the administrator , then set the ownership of the files previously copied out of the published web folder to the new user and move them back to the web folder.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The variable $go_info["server"]["dir_trenner"] must always be /, but the module name is missing. Which ISPConfig version do you use?

    The module name is missing in your session, but I have no idea why it is missing.


    This might work as well, but I guess this issue is not related to the files.
  3. tarndt

    tarndt New Member

    I use version ISPConfig 2.2.6
    I also noticed a Bug and can report this in a different thread if you like, but basically if you create a site under admin, and then create a reseller (but forget to grant DNS privledges) and move the site to the new reseller, the DNS entries stay in /var/named/chroot/var/named but are not viewable in DNS Manager from ISPConfig for any user. This means they can no longer be edited or deleted. Ideally a warning would be displayed indicating that the user you are transfering the sites to does not have DNS permission and entries should be deleted from /var/named/chroot/var/named as well as from DNS Manager. That way if the admin then granted DNS permissions, the reseller could add the DNS's again and the entries should populate in DNS manager. Any work around for this as I moved 4 sites before noticing and this was on our production server. I tried deleting the entries from /var/named/chroot/var/named and then re-checking the DNS check box but this add's the entry into /var/named/chroot/var/named and not DNS Manager.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can manage the DNS records in the DNS-Manager as admin or as reseller if the reseller has DNS priveliges. If you dont find the items, you can use the search function in DNS-Manager.

    By the way, never edit the named config files manually, your chenges will be overridden and you will never see the changes in the ISPConfig interface.
  5. tarndt

    tarndt New Member

    OK, the search seemed to work out well and allowed me to add the DNS entry back into ISPConfig. I still have difficulties with the Web-FTP opening only on the left side, but I guess I'll save that for another day when I will blow the account away and then re-add it. Thanks for all your help.

Share This Page