Web-FTP access

Discussion in 'General' started by KenKnight, Feb 13, 2007.

  1. KenKnight

    KenKnight Member

    Hi all,

    I did a debian perfect setup for my wife and everything except the web-ftp is working great.

    Under normal circumstances she uses smartftp etc. The problem is she wanted to be able to take advantage of the directory protection that web-ftp has built-in vs having to learn how to do it via a shell.

    When you login using web-ftp the first and last icons do not show up and the center icon "New Folder" does. At this point the browser just hangs and goes no further.

    I've tried Firefox, IE and opera. In opera, all the icons show up but nothing else. I even tried this on a domain that doesn't have anything published on it.

    Any suggestions?

    Also a complement is deserved at how well the user interface for ispconfig looks on all three browsers... that's just good programming right there!

    Cheers!
    Ken
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    How many files and folders do you have approx. within this website?
     
  3. KenKnight

    KenKnight Member

    Hi Till,

    Thanks for replying.

    Sadly I've tried with one that has maybe 100-200 files in various subdirectories and I've also tried a brand new clean site.

    I've compared their proftpd.conf file against the one on my server and they are identical with exception of ip addresses and host names.

    Also, I've noticed that we're seeing a lot of operation timeouts when trying to use the ftp protocol to this box. I'm not sure what it is, but it almost feels like its the authentication that is getting bogged down. Once you get authenticated everything runs at normal speed.

    Any suggestions on where to check?

    Thanks,
    ken
     
  4. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Just add this UseReverseDNS off to /etc/proftpd.conf
     
  5. KenKnight

    KenKnight Member

    Thanks alex. Sadly it didn't seem to help.

    Ken
     
  6. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Make sure you rebooted your computer or restarted ProFtpD as it will not take effect till then

    Also try adding IdentLookUps Off
     

Share This Page