web folder privileges are getting reset by ISPConfig

Discussion in 'Installation/Configuration' started by wpwood3, Mar 29, 2010.

  1. wpwood3

    wpwood3 New Member

    I have munin installed on my ISPConfig3 box with output directed to this folder:
    munin will not write anything to the monitor folder unless the parent folder, web, has chmod 0755 permissions.

    The problem is that ISPConfig3 keeps setting the permissions for the parent folder back to 0710. This happens whenever any changes are made in the ISPConfig3 admin control panel to that web domain.

    What to do?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There are several options:

    a) Create a custom vhost file in the sites enabled folder for munin.
    b) Use a subfolder within the apps vhost for munin (/var/www/apps)
  3. wpwood3

    wpwood3 New Member

    My solution

    Thanks for your quick reply, Till. You got me pointed in the right direction.

    Here's what I did. Please let me know if you see any problems with my approach.

    Create a new Apache config file for munin:
    vi /etc/httpd/conf.d/munin.conf
    Insert the following lines into the file:
    Alias /munin /var/www/munin
    <Directory "/var/www/munin">
        Options Indexes
        AllowOverride All
        Order allow,deny
        Allow from all
    Restart Apache:
    /etc/init.d/httpd restart
    Create a new folder and give ownership to munin:
    mkdir /var/www/munin
    chown -R munin:munin /var/www/munin
    Edit the munin config file to point to the new folder:
    vi /etc/munin/munin.conf
    change htmldir to point to /var/www/munin:
    htmldir /var/www/munin
    Secure /var/www/munin with .htaccess

    Now I can access munin from http://www.mytestsite.com/munin
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont see any problems with that, except that you have now a /munin/ url for every site on your server. Not sure if thats intended.

Share This Page